Trying to prune

Hi there,

After a processing task failed due to lack of memory when there was no reason to, I had a look at the resources used.

As I had used a lot of my ‘Disk image’ I have tried to do a pruning at Terminal but ,while the image command is working (see pic), it is not recognizing the prune one.

I’m following the suggested syntax so what might be wrong here or how can I clean up the Disk Image?

1 Like

Will it run successfully with just docker system prune?

Locally at least, it will not prune images from containers that are still running, so I have the best luck with it after issuing a ./webodm.sh stop.

Ok I will try those later, thanks

1 Like

Says no such directory:

Last login: Wed Apr 27 08:29:17 on ttys000
[email protected] ~ % ./webodm.sh stop
zsh: no such file or directory: ./webodm.sh
[email protected] ~ %

Is the syntax right?

1 Like

I removed the dot at the front and it didn’t reject it :slight_smile:

1 Like

If you use Homebrew or MacPorts on your Mac, you might enjoy Topgrade:

I use it on my Linux and Windows machines to manage updates for me.

Fun thing is it will automatically issue the Docker prune after updating all your Docker images/containers!

Not necessary as we have our webodm.sh and the Docker commands (which you’re using nicely now), but it might be something for you to look into in time.

Last login: Wed Apr 27 08:29:17 on ttys000

[email protected] ~ % ./webodm.sh stop

zsh: no such file or directory: ./webodm.sh

[email protected] ~ % /webodm.sh stop

zsh: no such file or directory: /webodm.sh

[email protected] ~ % docker system prune

WARNING! This will remove:

  • all stopped containers

  • all networks not used by at least one container

  • all dangling images

  • all dangling build cache

Are you sure you want to continue? [y/N] y

Deleted Containers:

7fbf2fcd1076e0e876e5293e44608941b19a057e775a21e90d5c17b358bb2ae9

Total reclaimed space: 1.095kB

[email protected] ~ %

I reclaimed 1kB!

However, still 128Gb of my disk image is still being used

1 Like

I don’t think I use either of those. Just a straightforward Mac Mini

1 Like

Do you have a lot of Tasks hanging around that you’re not using? Maybe clearing some of those out might help.

It also looks like webodm wasn’t stopped properly.

Do you still have the WebODM Manager program? It should be able to stop it for you.

When I use webODM etc I close everything else except Chrome to run it on. I think it needs an [Option] in the prune statement to deal with the Disk Image?

1 Like

Nope, just plain docker system prune will do the trick if everything is stopped.

Closing Chrome doesn’t stop WebODM, you’ll need to stop it using webodm.sh stop or WebODM Manger, or optionally force-stop it through Docker (I do not like this method).

Can you try using this command to stop it?

~/WebODM/webodm.sh stop

Last login: Wed Apr 27 15:54:02 on console

[email protected] ~ % ~/WebODM/webodm.sh stop

zsh: no such file or directory: /Users/julianperry/WebODM/webodm.sh

[email protected] ~ %

Does it need the ~ at the start?

1 Like

I’ve closed down the PC and rebooted and tried again but no change.

1 Like

Do I need the WebODM Manager open at all for purging or these commands? I’m trying to find the webODM path on my machine

1 Like

None of these any good? I know the Purge is rather brutal :slight_smile:

1 Like

That just ensures you’re working in your home directory. It seems like the fundamental issue is we don’t know where your WebODM directory is to issue the command to webodm.sh. Can you find that using Finder?

Nope, but it can handle start/stop/update for you nicely/easily.

I mean… They’d work, but you’d be starting from zero.

We can figure out a better way :slight_smile:

Here is what


a search produces: (putting in WebODM)

Does anything look at all promising?

You say Manager can do a stop - is that a better option? If so what command or feature?

1 Like

Yep, use the WebODM Manager application.

There is a stop button on the UI that will issue the right command for you.

Morning Saijin,

Ok, I have stopped webODM via the manager and then had to restart a container in Docker with the command line they suggested (docker run -d -p 80:80 docker/getting-started) so we have this in Docker:

Also, looking under ‘Images’ in docker we have:

Anything here worth removing?

Then I tried the prune command in terminal but it did not recognise it:

The Disk Image is still where it was:

As I’m fairly sure that the disk Image being nearly at my max setting is why I can’t do any more tasks in WebODM, I need to clear this. Any ideas?

1 Like

Oooh! Take that $ out of your commands :slight_smile:

The command needs to be precisely:

docker system prune

Nothing before it, nothing after it.