Trying to process my first photos. [ERROR] Not enough supported images in /datasets/code/images

Hello!

I have 900 jpgs to run, to test i have 40 .JPG from a DJI scan in a folder named images on my desktop, and also a copy in C/images.

I run in cmd or powershell the following command:

“docker run -ti --rm -v /desktop:/datasets/code opendronemap/odm --project-path /datasets”

but I get this error.

“[ERROR] Not enough supported images in /datasets/code/images”

I have Docker desktop windows installed and clicked share C in file sharing. Do I need to set up something esle? I’m very new to this and really appriciate help or something to get me in right direction.

Big thanks for your time.

Try referencing the absolute path to your desktop (c:/users/youruser/Desktop) instead of just /desktop.

if i do full path like this or even with /images i get the following response.

I run:
“C:\Users\jayjay>docker run -ti --rm -v c:/users/jayjay/desktop:datasets/code opendronemap/odm --project-path /datasets”

Response:
docker: Error response from daemon: invalid volume specification: ‘/host_mnt/c/users/jayjay/desktop:datasets/code’: invalid mount config for type “bind”: invalid mount path: ‘datasets/code’ mount path must be absolute.

Edit:
if I run
“docker run -ti --rm -v /desktop:/datasets/code --entrypoint ls opendronemap/odm /datasets/code/images”

I get no reply. I read in another thread this should list my .JPG in my images folder. So how do I mount properly? Does it matter if my files are .jpg not .jpeg?

Slash before datasets/code.