Has the issue with the following error been addressed?

[ERROR] Not enough supported images in /code/images



Can you provide some more details? How are you running OpenDroneMap (native install, docker install, WebODM)? What is the command you are running to try and start the processing?


hi, im having kind of similiar problems, or at least i get the same error message… while having pictures (from the testdatasets or from odm) im on windows 10, using this command: docker run -it --rm -v “$(pwd)/images:/code/images” -v “$(pwd)/odm_orthophoto:/code/odm_
orthophoto” -v “$(pwd)/odm_georeferencing:/code/odm_georeferencing” opendronemap/opendronemap

this is my error log:
[INFO] Initializing OpenDroneMap app - Wed Sep 19 19:04:40 2018
[INFO] Running ODM Load Dataset Cell
[DEBUG] Loading dataset from: /code/images
[DEBUG] /code/images
[ERROR] Not enough supported images in /code/images
[INFO] OpenDroneMap app finished - Wed Sep 19 19:04:40 2018

i also installed webodm and it works perfectly fine there… im not so sure what the problem is…

kind of unrelated: can i calculate the NDVI within webodm ?


@jkwon you have a project folder with an images folder inside? you can run docker from anywhere, try to cd into your project folder and then run your command to start processing.

some explaination from a while back via @dakotabenjamin:

The container gets destroyed anyways, so changing the name of the project folder inside is kinda pointless. /code/ was simply a easy place to put the project files since the container is temporary. It’s one less directory to create in the Dockerfile. You can change anything on the left side of the colon, if you want to put the outputs in a different dir as well

docker run -it --user root\
>      -v /absolute/path/to/images:/code/images\
>      -v $(pwd)/odm_orthophoto:/code/odm_orthophoto\
>      -v $(pwd)/odm_texturing:/code/odm_texturing\
>      --rm odm_image

$(pwd)/local-path is convenient shorthand to produce an absolute path

for different topics like your NDVI question, best to open a new topic. note, it has briefly come up in an OpenAerialMap integration into WebODM discussion when talking about an architecture for creating plugins, and in a What feature is more important to you? poll earlier this year.


Sorry about that. First of all I’m on a Linux machine using Ubuntu 18.04.1 and Open Drone Map v3.1. The error I posted was from the docker install:

docker run -it --rm -v /home/local/bhi/pamt/documents/odmprojects/images:/code/images -v $(pwd)/odm_orthophoto:/code/odm_orthophoto -v $(pwd)/odm_georeferencing:/code/odm_georeferencing opendronemap/opendronemap
[INFO] Initializing OpenDroneMap app - Wed Sep 19 20:24:18 2018
[INFO] Running ODM Load Dataset Cell
[DEBUG] Loading dataset from: /code/images
[DEBUG] /code/images
[ERROR] Not enough supported images in /code/images
[INFO] OpenDroneMap app finished - Wed Sep 19 20:24:18 2018

I’ve also tried installing it natively and have been struggling with the import ecto error, also using suggestions from @dakotabenjamin:

Traceback (most recent call last):
File “”, line 8, in
import ecto
ImportError: No module named ecto

I have not yet tried the WebODM flavor.


all your images for the dataset you want to process are inside your /home/local/bhi/pamt/documents/odmprojects/images folder?


ok, so yes i do have an folder with images (filled with images) in my project folder
my path is something like this C: User/my/documents/anotherFolder/
so i cd into “anotherFolder” and then try to run the above mentioned command and get the error.
having said that, i do have some other folders in “anotherFolder” maybe thats the crux?

if i try to run this command, docker is whining about an invalid reference format , of course while changing “absolute path” to a real absolute path to my images

ok thanks!

yes. so im not sure what im doing wrong, but thanks for helping out!


Yes they are.


eyo, go into settings, and check your shared drives in docker, make sure docker has access to your drive
good luck