Trouble outputting to correct coordinate system, is --proj argument removed?

I’m new to WebODM, so bare with me.

I have a set of images that I’ve been processing with other apps and online tools with great success. I looked into WebODM and thought I’d give it a try.

I have processed the same set of images (from a DJI Mavic Pro drone) using WebODM and the output looks pretty good. The only problem is that it’s not very accurately tied to the world (since it’s just using the GPS coordinates in the images). So I then decided to go to the trouble of obtaining ground control points with my survey crew and linking them to the photos. I created a gcp.txt file and it looks to be mostly working.

Problem: The output of the ortho photo & point cloud are in WGS84 UTM 15N. My gcp file has a header with a PROJ4 parameter of “+proj=tmerc +lat_0=35.83333333333334 +lon_0=-90.5 +k=0.9999333333333333 +x_0=250000 +y_0=0 +ellps=GRS80 +units=ft +no_defs”

Shouldn’t the output match the coordinate system that I have in my gcp file?

I tried running ODM from the command line yet I keep getting errors when I try and manually use the --proj argument. So, I ran ODM using the --help argument and I see that --proj isn’t even listed. Was it removed in a recent release? The document still lists this argument.

I’m running OpenDroneMap 0.8.2

Yes, it’s been removed (and we should update the docs). Could you help?

For consistency, all outputs are now in UTM. If you need to reproject it, use a tool such as gdalwarp after processing with ODM. We might improve this in the future (contributions welcome?). The --proj parameter was not very consistent with all outputs (it didn’t affect DEMs or point clouds) and we might favor the usage of EPSG codes in the near future.