Stripey DEMs

Apologies if this has been covered elsewhere but, if it has, I can’t find it. A colleague sent me some images to process into a DSM which I have done but, unfortunately, the DSM has these rather annoying stripes across it. I suspect(?) this is due to insufficient overlap. My question is, are there any settings within WebODM that I can try to improve this, or am I stuck with what I have?

1 Like

The white stripes running vertically?

Those are a display artifact I’ve seen on a few machines, but it should not be present in the data. Check with QGIS to verify.

If you mean the diagonal ones going across the fields, that just looks like normal field cropping.

Well, this is a new one. If you can do so without running out of memory, increasing your feature quality may be enough.

2 Likes

I saw the same white lines issue with a much older version, here:

and continued in the link below that post

1 Like

Its the diagonal lines I am talking about. These are artefacts, rather than cropping as the ground is rough grazing.

1 Like

The DSM was produced on the default “ultra” settings, but the diagonal stripes are also present on other default settings I have tried.

1 Like

Its not the white lines I am so bothered by. It is the diagonal stripes running across the DSM which are artefact - their orientation corresponds to the flight path of the UAV.

1 Like

Can you post a few sequential images (might need to scale them) covering the corner on the right?

Hope this will do…





Are they from around the top centre where the hedges cross? I was thinking the corner on the right of the DSM would be best to cover a very obvious part of the issue you describe, with no obstacles.

DSM-lines

I can’t tell the orientation from these images, do the diagonal lines correspond with the plough lines?

The stripes do not relate to the crop/plough lines, as they traverse areas which are rough grazing or not under the plough. It is related to the mapping. If you look carefully, you can see the continuing both sides of the hedge rows.

1 Like

OK, can you post the DSM with camera positions overlaid?

1 Like

So - in answer to my own question, by changing the settings to: feature type: hahog, ignore gsd:true, and matcher type: bruteforce, I have managed to almost eliminate the annoying stripes. I am now processing on ultra, with those modifications.

2 Likes

Thanks Gordon - you can see that the issue I was dealing with relates to the flight plan. However, by altering some of the settings, I have managed to improve things somewhat.

1 Like

Good that you are on the way to a nice result :slightly_smiling_face:

That setting is best avoided, it often leads to a failed task

3 Likes

Running with 128gb RAM and, thus far at least, haven’t run into any issues. That said, I do sometimes push things to the max so I expect, sooner or later, I’ll select something I shouldn’t have!

2 Likes

Yes, with 128GB it will be a while before you run into issues with ignore-gsd. :joy:

3 Likes

Just give me time, and I’ll sure I’ll manage to push it too far…

2 Likes

:joy: Seeing as I maxed out the RAM on a machine with 768, I have faith in you.

4 Likes