Ssl install problem on AWS ec2 instance

Thank you so much for the great support and wonderful product. I have been using it for the past 1 month and just simply love it. Excellent product and support !!!
I have installed webODM on aws ec2 instance and followed the instruction as per


and all worked fine. After that I restarted with ssl using my ec2 instance IP.
./webodm.sh restart --ssl --hostname (my ec2 instanceIP)

But I got this error !!! Should I use a registered sub-domain or Elastic IP?

webapp | make a secure backup of this folder now. This configuration
webapp | directory will also contain certificates and private keys obtained
webapp | by Certbot so making regular backups of this folder is ideal.
webapp | WARN: We couldn’t automatically generate the SSL certificate. Review the console log. WebODM will likely be inaccessible.
webapp | Using nginx SSL configuration
webapp | nginx: [warn] the “ssl” directive is deprecated, use the “listen … ssl” directive instead in /webodm/nginx/nginx-ssl.conf:43
webapp | nginx: [emerg] cannot load certificate “/webodm/nginx/ssl/cert.pem”: BIO_new_file() failed (SSL: error:02001002:system library:fopen:No such file or directory:fopen(’/webodm/nginx/ssl/cert.pem’,‘r’) error:2006D080:BIO routines:BIO_new_file:no such file)
webapp | INFO Initializing GRASS engine using /usr/bin/grass78
webapp | __ - … __ - _

Hi there, I’m with the same problem. Did you solved it? Cheers

IP is not an hostname. You cannot use an IP address; you first need to register/setup a DNS A record (e.g. demo.webodm.org), then pass the domain name in the hostname parameter.