SRS of GCP not used

HI, I have created a GCP and put in a proj4 code for the system I want to use UK OS control OSGB36 however when I run this it doesn’t seem to be picked up and uses WGS84 UTM 30N to geo reference the files. I have the GCP file in the directory above where the images are stored.
I am new to WebODM so was wondering if there is a setting I am missing?

Thanks for any help,

Welcome and have a good WebODM journey. ODM only processes in UTM. It can handle proj4 strings for input - but converts the GCP’s to UTM and runs the pipeline in UTM. All of the outputs are in UTM too. You can convert the outputs using QGIS or ArcMap. Good luck



Hi Mike
Thanks for the reply, I have used QGIS to convert the tiff so I can use that ok, however I want to use the pointcloud las file so can I convert that in QGIS?


To use LAS in QGIS, you’d need to be running the latest 3.18.x builds on Linux compiled with/against PDAL, or one of the QGIS 3.18.x Windows builds running against PDAL, which come through OSGeo4W-NG installer. These early 3.18.x Windows builds were pulled due to issues, however.

You could install FUSION and/or lastools in QGIS’s Plugins and setup the dependencies to do load/conversion from LAZ, but again, you won’t have 3D Point Cloud support unless you’re on one of the supported 3.18.x PDAL builds.

You’d need to see PDAL in the Providers section, like pictured below:


David, welcome. I’m not far away from you in Ireland. Yeah I can confirm that ODM converts to UTM. I have seen in a recent PR that the latest version of OpenSFM can use geographic SRS rather than just UTM.

Hopefully in an upcoming update @pierotofy can add the -EPSG flag that was never used. It would be huge for us to get outputs in Irish Grid or OSGB. Its probably the last big item in the way of our organisation adopting ODM.

Incidentally I tried installing QGIS 3.18 on Ubuntu and could only get 3.16. It was only to convert a Pix$d point cloud for import to WebODM but managed to get Entwine installed through docker.


HI, thanks for the reply, yes that function would certainly make life a lot easier and seamless.

I am using QGIS to transfer the ortho image to GBOS and trying CloudCompare to do a transformation of the cloud using the GCP as a reference, works not bad for my use.


I’m new to WebODM too and had a similar issue with the GCP file and UK nat grid. I ended up going through the CSV route (which unfortunately seems to ignore the RGB) and then using GridInquest2 to convert from UTM30 to OSGB36((TN15). That got me a decent geo-referenced point cloud.

Hope that helps.


Hi WGSJacob,

Thanks for this will give it a try. Do you know what the EPSG code is for the OSGB36 you are using please so I get the correct one?


1 Like

Give a check here, but this is also a great reference in general:

Hi David,

I haven’t actually used an epsg code yet … My GCP file is in WGS84 X,Y,Z and then all the conversions have been done using the Grid Inquest2 Program. From looking into it, my understanding is 27700 is UK 2D, and 7405 is UK 3D. Sorry I can’t be more help.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.