Sparse Sections In Point Cloud Compared To MetaShape/NodeMicMac

I’ve processed a data set of 106-112 tiff images. I originally processed on Metashape and repeated the process on WebODM (using dsm true, dtm true, ultra and ultra - have tried both pre matching neighbours and switching that off, no resizing of images, ignore gsd - i can post the settings as they’re all saved) and on node-micmac.

Metashape and node-micmac both produce a clean, fully consistent (no glaring holes) point cloud, but ODM is missing huge gaps that should have enough overlap to complete.

Unfortunately, I haven’t read anything in this thread that I haven’t already tried, so I’m at a bit of a loss as to how to fix it, or what the problem could be?

I’ve checked the PC’s in CloudCompare, just to double check it wasn’t a rendering issue in WebODM, but the gaps persist. Interestingly, the mesh and orthomosaics produced by ODM don’t show the gaps?

Any advice would be welcome.

Thanks in advance.



I’m sorry to hear you’re having difficulties with Point Cloud density.

Are you able to share your original data (the TIFFs), along with your processing settings, and a copy of your ODM Report PDF?

Also, what version of ODM are you using, and what is your OS/hardware environment like?


Hello and thanks (I’m not new just couldn’t login with my old credentials so signed up with my github :slight_smile: )!

Sure - I’ll have to send a link to it all via direct message if that’s OK? It’s data for a paper I’m writing at the moment so don’t want to release it into the wild just yet.


EDIT: WebODM 1.8.3 (ran the update yesterday).

OS: EndeavourOS (Arch Linux based)
Ryzen 2700, 32GB RAM with a 32GB swap file on an WD Black NVME drive, docker in separate 70GB partition and --media-dir flag used for data outputs.

1 Like

Hello again,

How do I direct message you with a folder link please?

I’ve prepped the data to share with you but I can’t see a message option?


Click on my profile picture and there will be a message option.

For example:

1 Like

Hmm, I seem to be missing that option?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.