[SOLVED] Issue with ClusterODM and linking WedODM Node

Hi folks,

So I am sure I am doing something wrong here… but this is the strangeness I am seeing:

image

I have 4 nodes; 1 is Windows (top one - it works great), the next 2 are Ubuntu machines just running NodeODM in docker. The 3rd node is from the WebODM… and its loading really strangely with a different API version. I have ran update, and it all looks good from that point of view.

ClusterODM is running natively on the same host as WebODM; so not in Docker. ClusterODM 1.5.3

This node looks find in WebODM as a processing node, versions ect all show up fine. But yes, going to port 3000 externally and not via the docker networking results in this.

[this is actually how lightning nodes look as well when I add them to the cluster directly]

Any ideas?

Cheers,

Jake

1 Like

Welcome!

Sorry you’re having a bit of trouble!

Have you made sure to use the Token for the WebODM node instance when you added it?

Hi there,

Seems I was being stupid… port 3000 is in use by clusterODM… I was adding itself to the cluster :wink:

Side note that - looks like I have lost what that token should be. Is there anyway to get it from docker instance? (I think in my adding/removing it, I cleared it)

2 Likes

Recursive job control! I love it, haha :rofl:
Thanks for stress-testing ClusterODM with that. Now we know that won’t fail!

Oof. Asking the tough questions. It is pretty trivial to get from the WebODM UI by going into the Node settings and viewing it there, but from Docker, I do not know.

1 Like

Its all good - a few other things were creating issues as well; so running

docker run --rm -d -p 3000:3000 opendronemap/nodeodm

separately, and setting --default-nodes 0 in my WebODM service control

Calling this all good; sorry for the distraction :slight_smile: but thanks for the super rapid responses! great community here.

… now to integrate lightning into my cluster…

3 Likes

Any updates for clarity needed in the docs?

2 Likes

Yes, please!

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.