Slowing down process

It is taking forever to process 5685 images running on a very high ec2 instance in AWS. The progress bar remains in the same position for over 10 hours.

What processing parameters have you chosen?

dsm: true, use-opensfm-pointcloud: true, ignore-gsd: true
This are the parameters used.

–ignore-gsd can be very, very, very resource intensive and can make reconstruction take orders of magnitude longer than it need to (if not outright fail).

Are you certain you need that parameter?

build-overviews: true, dem-euclidean-map: true, dem-gapfill-steps: 8, dem-resolution: 9, dsm: true, dtm: true, feature-quality: ultra, feature-type: hahog, force-gps: true, ignore-gsd: true, matcher-distance: 0, matcher-neighbors: 0, max-concurrency: 10, mesh-size: 300000, min-num-features: 4000, orthophoto-cutline: true, orthophoto-no-tiled: true, orthophoto-png: true, orthophoto-resolution: 9, pc-csv: true, pc-quality: ultra, pc-rectify: true, rerun-from: dataset, tiles: true, use-3dmesh: true

These parameters even make things worst. After 12 hours still in the same place.

Not really, if i am to leave it as false will make the task faster right.

I’m not surprised this makes things worse. You’re skipping all pre-matching and using HAHOG which is slower than SIFT in most cases, plus you have --ignore-gsd enabled still.

Try processing with defaults to get a sensible baseline for how long this dataset will take on your EC2 instance, and then carefully/selectively increase options as you go from there.

1 Like

Ok, thank you. Will follow through and get back here.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.