Settings for best forest reconstruction (open canopy)

Hi ODM community,

Has anyone had much success stitching drone data of open canopy forests? I’ve done a couple of flights now and whatever settings I use, it always seems to miss a lot of the trees. I’m using a DJI Phantom 4 and the pix4d app (i.e. decent drone and tons of overlap) and the outputs look fine in pix4d so I don’t have any reason to think it is a problem with the data. Data and output links below.

The forestry settings do a slightly better job (when it doesn’t crash) but enough trees are missing under all settings I have tried that at the moment ODM doesn’t seem like a viable option for working with this sort of data. Any suggestions or ideas on what I might be doing wrong?



Open landscape with patchy trees
Output (using ‘forest’ settings:
Arboretum forest (somewhat closed canopy)
Output: Map - WebODM - Australian Scalable Drone Cloud

  • Note this one isn’t as bad as the first one, but if you toggle between the point clouds and the DEM you can see there are a lot of trees missing in some of the forest blocks

Options: cog: true, crop: 0, debug: true, dem-gapfill-steps: 4, dem-resolution: 1, dsm: true, matcher-neighbors: 16, mesh-size: 300000, min-num-features: 16000, orthophoto-resolution: 1, pc-classify: true, pc-ept: true, pc-filter: 1, pc-geometric: true, pc-quality: high, use-3dmesh: true, verbose: true

This is what I have with the 97 images you uploaded to the CloudStor folder. It looks like roughly half the site/images you used for your reconstruction.


I’m in the middle of mapping similar country near Coonabarabran, and some of the areas I covered suffer from less than ideal overlap due to large land elevation changes across some flight plan areas. I’m using lower overlap 70/65 (at launch ground elevation).
Smaller areas, albeit at smaller GSD, are covered where the ground is closer to the drone flight height, and I’ve noticed holes in the orthophoto and the 3D point cloud and textures. However, the link is rather tenuous, as the holes in the reconstruction don’t line up all that well with the higher ground in all cases. I notice your flight altitude is closer to the ground along the ridge, but again, the holes don’t line up particularly well.

Sorry, not sure why the full dataset hadn’t uploaded.
Try this link, you should see 324 images which is the full dataset

1 Like

Re forest settings, I’m finding min num. features set to 10000 is plenty, and saves lots of processing time in open forest areas. M2P and 70/65% overlap for this set of 297 images.


That link to the images seems to have died.
This one should work