Setting hardware options in standard pay version 57$

Hi,sorry for that post but I am realy lost… I just bought that standard instalation version for 57$- I am just total noob in programming etc, so was too difficult to install webodm by myself…My problem is hardware utilisation settings-- I have i7-12700k, 64gb ram and rtx3070,win10 - but system monitoring programm shows me, that only very small amount % of them are being used durring proccessing…and when I tried to process over 315 photos, after 3 horus it showed message:You run out of memory, add more RAM…how to unblock, increase Ram usage and cpu and gpu??..I found on yt, that u do that in docker or sth, but I am not sure how to do that in standard 57$ paid version…I am not sure if I got with that installation anything like docker, or simillar thing to be able to adjust that settings…please, I am begging you to give me sth simple steps/hints how to solve it… thank you

If you’re on Windows you do not need to change any options; the software already uses all available resources. :clinking_glasses:

thx for response, however it’s not great news for me… I am just totaly surprised, that the same 314 photographs from my drone dji air2s Agi-soft metashpe sorted out in 1 hour (of course that was just high detailed 3d model of terrain only) and few days ago I did a terrain model from over 700 photos, the same drone 1 inch camera sensor- with no problems within 2 hours…durring that job graphic card and processor and ram were flying under full sails - 90-100%…all fans at maximum…so how is it possible, that webodm works only at 10-15 % on the same computer? and after over 3 hours rejects the project saying: u run out of ram…how many GB of RAM is ok for that program ( high qualty jobs)? 128?264? I am affraid thayt if I buy extra RAM it would be the same story…it really looks like there is sth wrong with usage components settins at my web odm…kind regards, cheers

Depends on your settings and image inputs. WebODM tries to use all available resources, when possible, but not always (thus the 10-15% utilization at some point during processing, which is not always).

Did you process using the “Defaults” settings? At what point did it fail? Can you copy/paste a copy of the last lines of the task output? And how much RAM do you have?

1 Like

I’m guessing you’re running this on Ultra settings?

When you’re setting up your task, set “pc-tile” to TRUE. This will break down the depth maps into groups, rather than trying to load them all into RAM at the same time. Metashape will figure this out on its own and do it for you, but WebODM needs you to set the option for that.

3 Likes

I have 64 Gb Ram, i7-12700k , rtx3070, …proccesing node :node-odm-1 (manual) , high resolution

Mm, out of curiosity, does it process if you add no-gpu to the task options?

and that was -probabbly the reason …PC-TILE ----- thanks --I did set that on true and after 4 hours my model was done in high resolution…thanks, cheers

1 Like

I tried that no-gpu and it started processing…I rejected that after 5 mins - when program was matching jpg-s, but looked like it was working in that way… however the solution for my problem- and I hope it was not coincidence only :smiley: - was to enable pc-tiles … thanks a million …cheers

1 Like

one important or maybe not edit-- my comp. spec is NOT 64 gb RAM but 32 gb

1 Like

It’s amazing how much RAM it takes to do the depth maps if you’ve got enough images at high enough resolution. I’ve got 96 GB and that’s still not really enough for some of the data sets that I’ve got to work with.

1 Like

Yeah really crazy, we work with UAV data all the time for work using other software and only get provided laptops with 32gb ram. Amazing how much is required and hoops needed to jump through to get things working.