Setting GSD

Hello everyone again! I just got done doing some drone flying the other day over one of our test plot fields. I am able to get it processed but it keeps processing at 5cm GSD when I flew at a resolution of 1.9cm GSD. The drone is a Phantom Pro 4 v2 flown at 225FT with 75% front and 75% side overlap. I am processing on the installer version on WebODM. The data set is 797 pictures.

Here are the settings I was using when my computer keeps getting hung up trying to force the GSD

dsm: true, feature-quality: ultra, ignore-gsd: true, min-num-features: 12000, orthophoto-cutline: true, orthophoto-resolution: 0.001, pc-quality: high, use-hybrid-bundle-adjustment: true, rerun-from: dataset

This is the code where it sits at for over 24 hours.
[INFO] running pdal pipeline -i C:\Users\zed18\AppData\Local\Temp\tmp18pkp30m.json
[INFO] running pdal pipeline -i C:\Users\zed18\AppData\Local\Temp\tmp_7k7q2w2.json
[INFO] running pdal pipeline -i C:\Users\zed18\AppData\Local\Temp\tmpp0chqpkz.json
[INFO] running pdal pipeline -i C:\Users\zed18\AppData\Local\Temp\tmpntu16m_t.json

Now I understand that PIX4D operates in a completely different way, but when I ran my set through it. It reported at 1.9CM GSD.

I am interested in knowing how to tell it the GSD you want? Is there anyone that would be able to help/explain this to me?

Here is a report snip of both programs

PIX4D Compare WEBODM Compare

Try using orthophoto-resolution 1.9

You’re forcing a GSD of 100 micron per pixel :grimacing:

orthophoto-resolution — OpenDroneMap 2.6.0 documentation

Thanks for the response! I did that and still got 5 GSD.

I ran only 5 images with that setting to see if it would work. I am still getting the same result.

Here is a google drive link to the images, 100MEDIA - Google Drive

Here are the exact settings I used for the 5 images.
dem-resolution: 1.9, dsm: true, feature-quality: ultra, ignore-gsd: true, min-num-features: 12000, orthophoto-cutline: true, orthophoto-resolution: 1.9, pc-quality: ultra, rerun-from: dataset

What am I doing wrong? Would you mind trying a small set of the images to see what you get?

Thank you again for the help!!!

1 Like
Options: cog: true, crop: 0, debug: true, dem-gapfill-steps: 4, dem-resolution: 1, dsm: true, matcher-neighbors: 0, mesh-size: 300000, min-num-features: 12000, orthophoto-resolution: 1, pc-classify: true, pc-ept: true, pc-geometric: true, pc-quality: high, use-3dmesh: true, verbose: true

report.pdf (4.0 MB)

image

image

Returning an estimated GSD of 2.0, which is just about spot-on.

Thank you so much for that! Looks great! I am using the same settings you provided and still getting 5 GSD???

I am really confused about this. I attached a screen shot of my WebODM settings and the Quality Report.

WebODM Quality Report
WebODM Screen Snip

1 Like

Hmm… I’m using 2.6.1 via Lightning right now, so perhaps we’re missing a fix/change in the Windows 2.5.7 build at the moment?

Let me try re-processing locally to see what happens.

Sounds good. I am re running it but with image resizing off to see if that changes anything.

1 Like

YES!!! I turned off resizing images. Finally!!!

WebODM 2GSP|690x431

2 Likes

So turning resizing images off finally got you the GSD results you expected to see? I have been having similar problem, but wasn’t touching resizing images as it says somewhere in manual that resizing should not affect the final orthophoto quality. I guess it does?

2 Likes

From my experience it does, after turning off resizing, my GSD was right where I want it.

2 Likes