Running out of memory when generating texture patterns

I am running OSM on a set with 750 images on a Windows installation with 32 GB an 4 CPU:s assigned to docker. I use the following command:

docker run -ti --rm -v F:/datasets:/datasets opendronemap/odm --project-path /datasets vastra --orthophoto-resolution 10

I get
Exception: Child returned 137
when generating the texture patches

I have tried using the option --use-opensfm-pointcloud as suggested in issue #445, but the parameter is not accepted in the build of ODM that I am using.

I have tried the option --fast-orthophoto, but it generates the same error.

I need help to find a workaround, as this is a real showstopper.

My images are uploaded to Dropbox on:


1 Like

Mm, strange. Does it work with a smaller subset? What if you decrease the resolution (say, 15)?

1 Like

Decreasing resolution to 50 makes it work.

At first I tried to change the resolution and rerun without deleting the output files, and those changes had no effect att all. The choosen resolution probably affects the output of some previous stages and makes the pattern generation stage to fail.

Which output files should I remove in order to get the effects of the changed resolution? Playing high-low by removing all output files and rerunning the entire pipeline is quite time-consuming.