Resolution Struggles

Hi All - I am relatively new to WebODM. I have run several iterations using WebODM Lightning, however I continue to struggle to reach resolution anywhere the raw images being fed. See screen shot below of a drainage grate (raw image on right, ortho on left). I am running highest resolution (1 cm/pixel) and brown lens and believe there is plenty of overlap. Any thoughts would be appreciated. Thank you in advance.
Compare Ortho vs Orig

1 Like

Hi Scott,

I’m also new to WebODM, but I will try to help.
Fisrt, I believe ortho is showing the requested 1cm/px resolution, it’s only my perception without the real data. But I also think the real GSD is lower than that, so there is enough available information for a higher resolution.

What if you remove gps exif data from images?

1 Like

Wow, your actual GSD is quite high!

Set your desired orthophoto resolution with the following option: --orthophoto-resolution 0.1 (0.1 being 0.1 cm – your dataset may require a different value), and then if that doesn’t work on it’s own, you may have to override the resolution estimates that ODM is doing by setting the --ignore-gsd flag.

The danger with --ignore-gsd is that it throws away some memory optimization and other goodies, so you may need more RAM, if your dataset is sufficiently large.


Thank you for the feedback. I will give these a try today.

1 Like

Unfortunately, I am running in Ligthning…and the GUI throws error codes for anything under 1.0 for ortho photo-resolution and/or entering --ignore-gsd. I am thinking there is not any way around this for WebODM Lightning?

Thanks again.

Mmm. Yup. Lightning is probably restricted to help balance the demands on the system. You may have to self host, or rent a machine on the cloud.

If you want to test before doing so, shoot me a link to your data and I’ll process it one of my nodes so you can see the results.

1 Like

I ran some local attempts w/ smaller subsets and results are significantly improved. Bummed Lightning limits this…but understandable I suppose. Thanks again for your help!