--resize-to -1 seems to produce an error


I have a fresh installation of Ubuntu 16.04 and ODM. I tried to disable resizing using the --resize-to -1 but the ODM is complaining:

[ERROR] Resize parameter must be greater than 0

Am I doing something wrong?

I think resize-to is now disabled by default.

oh, but how we disable resizing? I am seeing ODM going ahead and resizing the images to 2400 pxl.

What version are you running?

The latest 0.3.1 retrieved from https://github.com/OpenDroneMap/OpenDroneMap/releases
The ubuntu 16.04 installation is also fresh.

Well, I used a second system and performed again a clean Ubuntu 16.04 installation and OpenDroneMap 301. The ODM finished without reporting any problem, but the issue persists. The system spits out the same error with the --resize-to -1 selection.

Is there anyone to confirm that the --resize-to -1 is still the way to go to disable resizing? If yes then we might have a bug. If not then how we do it?

Thanks in advance!

In version 0.3.1 unfortunately you cannot disable resizing. A workaround of course is to set the resize to the size of the largest side.

I recommend trying the master branch which does not resizing of the images.

Sorry for the confusion!

1 Like

Has the resize parameter issue been resolved in a release since? I was running a dataset via WebODM with resize-to: -1 and the task still showed as going through a “Resizing images…” stage.