Resetadminpassword gives an error message

After a crash of webODM i tried to restart it, but I cannot login anymore:
Invalid credentials. Note that both fields are case-sensitive.

So i tried to do a reset of the admin password with:

./webodm.sh resetadminpassword "Test123"

This generates the following error message:

./webodm.sh resetadminpassword "Test123"       
Traceback (most recent call last):
  File "/webodm/manage.py", line 22, in <module>
    execute_from_command_line(sys.argv)
  File "/usr/local/lib/python3.9/dist-packages/django/core/management/__init__.py", line 381, in execute_from_command_line
    utility.execute()
  File "/usr/local/lib/python3.9/dist-packages/django/core/management/__init__.py", line 375, in execute
    self.fetch_command(subcommand).run_from_argv(self.argv)
  File "/usr/local/lib/python3.9/dist-packages/django/core/management/base.py", line 323, in run_from_argv
    self.execute(*args, **cmd_options)
  File "/usr/local/lib/python3.9/dist-packages/django/core/management/base.py", line 364, in execute
    output = self.handle(*args, **options)
  File "/usr/local/lib/python3.9/dist-packages/django/core/management/commands/shell.py", line 92, in handle
    exec(sys.stdin.read())
  File "<string>", line 1, in <module>
  File "/usr/local/lib/python3.9/dist-packages/django/db/models/query.py", line 309, in __getitem__
    return qs._result_cache[0]
IndexError: list index out of range
Could not change administrator password. If you need help, please visit https://github.com/OpenDroneMap/WebODM/issues/ 

I searched (and found) a similar problem here and tried the solution that was given by [Saijin_Naib]:

./webdom.sh stop
./webdom.sh down
./webodm.sh update
./webdom.sh start

But this made no difference. Any ideas how to solve this?

1 Like

Does your distro ship topgrade? Can you make sure everything is fully up to date before you try again?

I’m not shure what you mean by that…

But at the moment i managed to reset the password, by restarting the browser, going to http://localhost:8000/dashboard/, and using the resetadminpassword command in the terminal.
Not shure what happened, but when i recall it:

  • Webodm gave me an error message that is was out of memory
  • I checked Docker and allocated more memory
  • I also saw that my internal harddisk of my MAcMini wasd almost completely full, so i changed the Disk Image Location in Docker to another drive and restarted Docker
  • Docker got stuck in the Restarting… process, so i killed the proces and restarted the computer.
  • After that Docker started up normally, but when i started Webodm (./webodm.sh start ) it took a very long time, and it seemed that it did a completely new install?
  • After that i couldn’t login, and the resetadminpassword didn’t work
  • So eventually i restarted the browser, go to http://localhost:8000/dashboard/ and saw the “confetti screen”. In the terminal i was now able to use the resetadminpassword command ands login to webodm, to see that all my projects were gone ;-(

Is there a way to get them back? I tried to set the d\isk image location in docker to its original location, but it gives an error message thet the DockerDesktop location already exists (wich of course is correct, but the point is i want Docker to use this original location so i hopefully will get my projects back)

Appareantly i did something wrong, and i hope someone can point it out to me so the next time i don’t make the same mistake…

1 Like

If your disk almost filled, something could have failed to write out and got corrupted. I’m not sure if you did anything wrong aside from run low on resources.

Always nice to hear that i propably didn’t do anything wrong :grimacing:

Is there any way to get my projects back, or are they lost forever

1 Like

I’m not really certain… It depends upon if Docker trashes the filesystem images when you set a new directory or not. And whether or not those images got corrupted due to the low disk space condition or not…

Have you taken a poke around to see if the filesystem image is still in the original location?

Do you mean the location of the Docker.raw file? That still exists in the original location
And I still have the output of the projects, because i start up WebODM with the --media-dir option. So that is no problem. But i would like to recover the projects so i can quickly view the settings, and use the viewers (3D and DSM/DTM/Ortho) to quickly inspect the results

1 Like

Can you export the projects to the all.zip format from the WebODM UI? No, right?

ojects are gone… So there is no way i can export them to all.zip

1 Like

You may be able to mount the raw file and extract the projects from that, zip them, and then import them.

Thanks again for the reply. I tried to find a way to mount the raw file, but without succes. Do you know a way how to mount it on a mac?

1 Like

Unfortunately, I do not. I don’t have access to a Mac to try and figure it out, either.

It should be an ext4 volume, so perhaps if you have access to a Linux machine you could poke around in it there?

I installed VirtualBox, and run Ubuntu from it. Now i have to figure out how i can mount the docker.raw file…

1 Like

You may have luck with xarchiver or peazip opening it directly.

Or, you might be able to directly boot the image via VirtualBox.

peazip could open the .qcow2 files, but with errors. It couldn’t open the .raw file. I did not succeed in mounting the raw file in VirtualBox. So i created the projects from scratch
Thanks for your support

1 Like

Is that file something you can share?

I wonder if working out a recovery workflow isn’t worth adding to our docs for these rare (but disastrous) edge cases.

At the moment i have a slow internet connection. In about 1 month i will have a much faster connection. The docker.raw file i have is about 110GB in size. Uploading it now to files.com will take about 4-5 days according the site…

1 Like

It isn’t time critical for me, just wondering if I can work something out for us and maybe get your projects back to you intact :sunglasses:

Whenever works for you works for me to take a poke at!

I’ll let you know when i’ve uploaded the file. Thanks for all your reply’s :+1:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.