Rescaling problem

Hi there,

we are encountering rescaling problems with our ODM output orthophotos (1cm GSD), which are shrinked compared to their original size. Our baseline settings use --gps-accuracy=0.2 (RTK corrected survey, Zenmuse X-7) and --fast-orthophoto + -- skip-3dmodel=TRUE + dem-resolution=2. We are only interested in orthophotos.
After some reading in the forum, we found posts that point out, that the options --gps-accuracy and --fast-orthophoto mentioned above could cause the rescaling issues. Here a screenshot examplifying the rescaling issue. The image is slightly too small and should in reality scaled to the field boundary (blue line). Our Pix4D ouput scaled correctly to the field boundary:

So we did a test running the default settings, which need longer processing times than our baseline settings, but should be potentially more precise to see if the rescaling issue is solved. The result was actually the contrary.The image was significatly shrinked in comparison to its original size. Pls have a look at the screenshot that shows the scaling problem compared to the field boundary:

Here the tracking deatails for both settings. Why there are some apparently incorrectly calculated camera positions by SFM, when using default settings?:

What went wrong here? Both have the same input images and reconstructed images count:

Both were processed in the same pipeline (scalable VMs in Google Compute Engine) in the cloud. It is very appreciated any information that can help us understand how to deal with the scaling problem in ODM, that we are facing. We need geospatially accurate images for our analyis.

Best,
Gabor

1 Like

Please share the full set of processing parameters, full report, and images as you are able. This is not typical or common, so there aren’t any quick fixes without further context.

1 Like

Hi Steven, thank you for having a look. I will prepare a zipped folder with the raw input images + odm_settings file for the baseline settings + the 2 reports. The default settings are entirely default, that means with a 5cm GSD, but I suppose, that this should’nt have caused the problem.

Best,
Gabor

1 Like

It’s probably gps-accuracy. Try to relax it a bit (e.g. try 1 or 2 instead of 0.2).

3 Likes

Good call. Piero is right: start there, the model is over-constrained and your accuracy isn’t as good as you think.

Generally, if the GPS accuracy claims to be 0.2m, it’s effectively (at best) 0.4m (0.2 in any direction). If you write the GPSZAccuracy and GPSXYAccuracy flags, ODM will now use 2x the max of those, and that’s a good starting place for your data if you’re setting it globally. 1-2m is even safer.

2 Likes

Hi Pietro, we ran --fast-orthophoto with the default --gps-accuracy setting of 10m and the result was identical to the one, using 0.2m. So my assumtion is here, that option --gps-accuracy didn’t impact on the rescaling issue.

I am preparing the data to share.

Best,
Gabor

1 Like

Try Piero’s suggestion: it’s a very quick check. Your track details strongly suggest an over constraint of GPS accuracy.

If it doesn’t work to relax that, we can take a look at the data.

1 Like

Ok, just to get it right, you want me to run the default settings except > --gps-accuracy: 2 and --orthophoto-resolution: 1.0, correct?

Best,
Gabor

1 Like

Default but try setting gps-accuracy to 0.4. If that doesn’t work, try gps-accuracy of 1.0.

2 Likes

Hi Stephen,

after having applied gps-accuracy 2m according to the recommendation of Piero, the default settings are not having anymore these outliers and the scale is better. But the (potential) smaller scaling problem remains. I also tried gps-accuracy 0.4m and it didn’t change. There is an offset between the image and the survey boundary, which was passed to ODM to crop the image. I checked the boundary coordinates, that are passed to ODM and they are identical with the one you see on the screenshot.


I will send the data to have a look at.

Best,
Gabor

1 Like


even I got the same results . I ran the following command with GCPs.
docker run --rm -v /home/sharu/datasets:/datasets opendronemap/odm:latest --project-path/datasets feature-quality ultra --dtm --dsm --dem-resolution 3 --orthophoto-no-tiled --cog --time’ --skip-band-alignment --skip-3dmodel --gcp /datasets/gcp_list.txt

it got located correctly but it got shriked!

1 Like

why it is getting rescale or shrink? are my GCPs wrong?