Questions about different settings

Hi. I’m new to the forum and have a few questions about the different settings in WebODM. I have problems getting good results when using the preset settings. I have tried different settings and spent many hours trying to find some settings that work. Most of the time i can’t even get webodm to run with any quality settings above medium. Models are not detailed enough in medium setting, but I never found a way to get it to run in high or ultra settings. I would appreciate some pointers and tips on how to get the program to run to completion with settings above medium.
Currently I’m working on a complex 3d model with 1135 20MP pictures taken with a Air 2s using Dronelink. I’m at 85% overlap and grid pattern from above, 80% overlap from sides, every angle is covered. Actualy more than enough pictures.
I have run this dataset in Pix4d, Meshroom and Metashape with no issues but I can’t get this model completed at all in WebOdm. There is definitely something I’m doing wrong, but what is it?

Sytem: Win11, i7-12700, 64gb ram, 3060ti.


I use ultra all the time with no issues.

The best settings I’ve found is Hahog with Flann and 15000 features. Also I split at 250 with like 20 overlap to make it work with my amount of ram(64).

But I normally don’t do proper ortophoto because it eats ram, I make an ortophoto from the pointcloud in CloudCompare.

Hope something of that helps.



Andreas got you pointed the right way!

Try increasing the Windows page file to 2-4x RAM size, or most ideally, increasing your physical RAM.

You are having issues above medium because you are running out of memory with that size Task at 20MP.

Thanks guys! I actually had forgotten to set the virtual memory but didn’t think any of it sins I had no issues in Pix4d and the other programs. I might upgrade my ram, I left room for 64gb more so i guess that is the long term solution.
I will try to run the data again with the virtual memory set to a propper amount and see what happens.
Thanks again

1 Like

Don’t forget split!


This might sound dismissive/flippant, and I assure you that it is not meant to be, but each photogrammetry suite is quite different from one another, and how reconstruction happens is different, especially if you used, say, Pix4DFields instead of Pix4DMapper and you’re comparing that to the default WebODM reconstruction.

We are working on profiling resource usage and consumption, since we know this is a pain-point for our Community. We’ve recently implemented some more robust fall-backs when we identify some common Out-Of-Memory causes which should help reduce the issues you’re experiencing, but we aren’t catching and fixing them all quite yet (though we are working towards that!).

Please let us know how it goes on 128GB RAM + Pagefile (I think you’ll be quite happy :slight_smile: ).


Hi again. I finally had some time to test out a few things. Some is working, others not. I have reduced the number of pictures in my models to 350 - 400 (20MP) for testing purposes. Some models come out ok, but i need more detail.

These settings are giving me som problems. Is there something I need to change? Is it still a RAM issue? I don’t know if all RAM usage shows in task manager, but it the most usage by WEBODM is about 24GB

[INFO] DTM is turned on, automatically turning on point cloud classification
[INFO] Initializing ODM 3.1.1 - Fri May 26 08:23:23 2023
[INFO] ==============
[INFO] 3d_tiles: False
[INFO] align: None
[INFO] auto_boundary: True
[INFO] auto_boundary_distance: 0
[INFO] bg_removal: False
[INFO] boundary: {}
[INFO] build_overviews: False
[INFO] camera_lens: auto
[INFO] cameras: {}
[INFO] cog: True
[INFO] copy_to: None
[INFO] crop: 3
[INFO] dem_decimation: 1
[INFO] dem_euclidean_map: False
[INFO] dem_gapfill_steps: 3
[INFO] dem_resolution: 5
[INFO] dsm: True
[INFO] dtm: True
[INFO] end_with: odm_postprocess
[INFO] fast_orthophoto: False
[INFO] feature_quality: high
[INFO] feature_type: hahog
[INFO] force_gps: False
[INFO] gcp: None
[INFO] geo: None
[INFO] gltf: True
[INFO] gps_accuracy: 10
[INFO] ignore_gsd: False
[INFO] matcher_neighbors: 0
[INFO] matcher_type: flann
[INFO] max_concurrency: 32
[INFO] merge: all
[INFO] mesh_octree_depth: 11
[INFO] mesh_size: 300000
[INFO] min_num_features: 15000
[INFO] name: 623bf505-5bdf-438e-86e7-21988bd10025
[INFO] no_gpu: False
[INFO] optimize_disk_space: False
[INFO] orthophoto_compression: DEFLATE
[INFO] orthophoto_cutline: False
[INFO] orthophoto_kmz: False
[INFO] orthophoto_no_tiled: False
[INFO] orthophoto_png: False
[INFO] orthophoto_resolution: 2.0
[INFO] pc_classify: True
[INFO] pc_copc: False
[INFO] pc_csv: False
[INFO] pc_ept: True
[INFO] pc_filter: 2.5
[INFO] pc_las: False
[INFO] pc_quality: ultra
[INFO] pc_rectify: False
[INFO] pc_sample: 0
[INFO] pc_skip_geometric: False
[INFO] pc_tile: False
[INFO] primary_band: auto
[INFO] project_path: D:\WebODM\resources\app\apps\NodeODM\data
[INFO] radiometric_calibration: none
[INFO] rerun: None
[INFO] rerun_all: False
[INFO] rerun_from: None
[INFO] rolling_shutter: True
[INFO] rolling_shutter_readout: 0
[INFO] sfm_algorithm: incremental
[INFO] skip_3dmodel: False
[INFO] skip_band_alignment: False
[INFO] skip_orthophoto: False
[INFO] skip_report: False
[INFO] sky_removal: False
[INFO] sm_cluster: None
[INFO] sm_no_align: False
[INFO] smrf_scalar: 1.25
[INFO] smrf_slope: 0.15
[INFO] smrf_threshold: 0.5
[INFO] smrf_window: 18.0
[INFO] split: 250
[INFO] split_image_groups: None
[INFO] split_overlap: 20.0
[INFO] texturing_keep_unseen_faces: False
[INFO] texturing_single_material: False
[INFO] texturing_skip_global_seam_leveling: False
[INFO] texturing_skip_local_seam_leveling: False
[INFO] tiles: False
[INFO] use_3dmesh: False
[INFO] use_exif: False
[INFO] use_fixed_camera_params: False
[INFO] use_hybrid_bundle_adjustment: False
[INFO] video_limit: 500
[INFO] video_resolution: 4000

I would set pc-filter to 1 and pc-sample to 0.02 or something to get more detail but not to many points.

Thank you.

Skal teste litt forskjellig her :+1:

1 Like

Gör det!

1 Like

Very likely a RAM problem, yes.

You need enough address space for certain stages, so RAM+swap/pagefile, but that doesn’t mean that it will be allocated the entire time, or that you’ll even see it. It will just simply fail a step if the address space isn’t big enough.