Processing Thermal Images

Hello, I have thermal infrared images acquired using the DJI Matrice 300 RTK H20T payload. I tried processing them using the multispectral option in WebODM but I got the error ‘Cannot Process Dataset.’ Checking the stacktrace, the error seems to occur during reconstruction.
After a lot of trial and error, I was able to process the images using the ‘Buildings’ option in WebODM. The output (3D model & orthophoto) is very decent considering the images are 640 by 512 pixels wide which is quite poor. The problem however is that I can’t find the reflectance/temperature values from the outputs. Whenever I try checking the ‘Radiometric Calibration’ option, the processing fails again.
Is there any way I can resolve this?
I’m using WebODM 1.9.2 installed using Docker on Ubuntu 20 machine. Thanks.

1 Like

Hmm… I wonder if we don’t support that sensor fully yet.

Do you have test data you can share?

1 Like

This used to happen with our P4 Multispectral, and a work arount, is, procesing them automaticly, but canceling immediately, and then restarting IT, BUT click on the triangle first, and select “LOAD FROM DATA SET”. Some How automatic does not read the images data to proces correctly, so after forcing it, it just worked.

Hope it helps.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.