Processing stops at Depthmapping (No issue report)

From @jamesoutdoorrobotics on Thu Apr 13 2017 02:30:48 GMT+0000 (UTC)

Greetings! I have a small issue that I had a question about for WebODM and NodeODM.

Working on processing imagery over 100 photos per instance. Both on WebODM and NodeODM. Both, with image amounts at, or over 100 do not complete their processing tasks and stops processing altogether with no error report. I have attempted to run several instances to narrow down any possible causes with my systems processing capabilities. Tested Pix4D on same system and could process 2135 images with no failure, so I imagine the processor and RAM can handle the heavy workloads for extended time periods. Does this has to do with restrictions in the current application stack or could there be some other issue causing the depthmap process stop to occur. I checked had the task log running in git bash and it displayed no issues. Screen capture below.

Is there a photo processing restriction/limitation with the current software used in the ODM stack?

Thanks! Please let me know if there is anything I could possibly do to help in resolving this.

Copied from original issue: Processing stops at Depthmapping (No issue report) · Issue #147 · OpenDroneMap/WebODM · GitHub

From @pierotofy on Thu Apr 13 2017 12:42:22 GMT+0000 (UTC)

Hi there! We don’t impose any limit on the number of images, so as long as your system has enough power it should be able to process them.

With that said, this software is still beta, so things are not stable yet, and we’ve had some issues with the depthmap processing hanging.

If you could share the dataset that you are using (or a subset of it) so that a developer could try to reproduce the issue, that would be of tremendous help.

@dkbenjamin have you seen this problem before?

From @mcjackattack on Thu Apr 13 2017 16:49:12 GMT+0000 (UTC)

I am getting this too. It will stop on a random image, process hangs on the depthmap, I tried updating and it does the same thing. I will post a link to the images I am using later, its only using 10% of one CPU(out of 10) so is not the processing power that is the issue.

From @jamesoutdoorrobotics on Thu Apr 13 2017 23:30:22 GMT+0000 (UTC)

@pierotofy Thanks for the reply! I have uploaded the same data set that I have been testing on Web and Node ODM. Here is the link for the set.

From @pierotofy on Mon Apr 17 2017 13:18:47 GMT+0000 (UTC)

I haven’t been able to test this yet, but I plan to in the next few days. Sorry for the delay.

From @jamesoutdoorrobotics on Wed Apr 19 2017 12:57:23 GMT+0000 (UTC)

@pierotofy No worries and thank you for taking a look into this!

From @pierotofy on Thu Apr 27 2017 00:30:38 GMT+0000 (UTC)

I ran the dataset a few times but it errored out because I didn’t have enough disk space on the machine I was processing the dataset on. I’ll retry again after cleaning up some space.

From @pierotofy on Sat Apr 29 2017 20:04:47 GMT+0000 (UTC)

Ok I confirm that this is getting stuck on the depthmap computation process. A task has been running for 2 days and it’s stuck at Computing depthmap for image DJI_0138.JPG.

I’ll try a few things and report back my findings.

From @pierotofy on Sun Apr 30 2017 18:44:09 GMT+0000 (UTC)

I was able to get further by checking the use-pmvs option, which uses pmvs instead of opensfm to generate the point cloud. My process was then killed because I tested it on a machine with little RAM (4 GB), but I’m guessing it would have continued without issues from there.

@jamesoutdoorrobotics would you be able to try to reprocess the dataset with use-pmvs?

Also, it would be worthwhile to open an issue with, since this seems a fault related to their code.

From @rakkenrol on Mon May 01 2017 10:13:39 GMT+0000 (UTC)

Dear All,

I had the same problem this weekend. After I set ‘use-pmvs’ then I was able to make a run. At the end I have got the following error message: "refinePatchBFGS failed!"
Do you have any idea to solve this?

Thank you!

From @dkbenjamin on Mon May 01 2017 13:13:14 GMT+0000 (UTC)

The refinePatchBFGS failed! message is just a warning and can be safely ignored. You should get a successful run out of that.

From @rakkenrol on Mon May 01 2017 14:52:32 GMT+0000 (UTC)

Thanks @dkbenjamin, I am sorry, but I am fogot to mentioned that at this point the process has stucked… :frowning: So I am not able to download the results…

From @dkbenjamin on Mon May 01 2017 15:05:31 GMT+0000 (UTC)

Can you post the error that causes it to fail? You may be running into memory issues.

From @rakkenrol on Mon May 01 2017 17:06:45 GMT+0000 (UTC)

There is no error message. Is still running, but nothing happens. I allocated 12 GB RAM in Docker. Can I do anything else? Thanks a lot!

From @pierotofy on Sun May 14 2017 21:06:12 GMT+0000 (UTC)

I would open an issue with OpenSfM.