Processing images from DJI Spark gives "Process exited with code 1"


#1

Hello. I haven’t been able to process images from a DJI Spark. I’m using the standard processing options, on macOS 10.13, Chrome v69, and I installed WebODM with the macOS installer, updated an hour ago.

I’ve processed data sets from a Mavic Pro on WebODM and they work fine.

Here’s an example data set that fails with the message “Process exited with code 1”.
https://drive.google.com/open?id=1V0WvET4EeYBpCcUkbuHCOuQxR0V1Z3ca

I can see a warning in the output “Could not find ccd_width in file” but when I use --force-ccd it doesn’t resolve the processing fail.

The task output is here:
https://drive.google.com/open?id=1T_2I51_RYAd7NAJ2IE2mlGoArvObJpVd


Invalid value encountered in divide
#2

Hi - any ideas about this issue? Is there something about the Spark that makes it unsuitable for WebODM, or is it the way I’ve captured the images?

I tried the same dataset with Agisoft Photscan Standard and the result was really nice, but for the students I’m teaching I’d prefer to use WebODM.

Thanks.


#3

No thoughts on this? Is WebODM unsuitable for processing Spark imagery?


#4

Hi @darylwm — have you updated the spark? There’s a bug in the firmware that is preventing its use in OpenDroneMap. We could write a workaround for the bug, but as it’s being patched (or has already) this isn’t a high priority item.


#5

Hi @smathermather-cm - it’s running Aircraft Firmware V01.00.1000, the latest. Which bug are you referring to?

The Spark’s precision in its GPS coordinates seems much lower (4 decimal places) than the Mavic (8 decimal places). That probably wouldn’t help.


#6

I met the same problem. Have you solved it?


#7

I once succeeded in mapping with spark about half a year ago, but today it does not work.
) :


#8

Unfortunately the Spark only records 4 decimal places for the lat/long in the EXIF header of each image, which is very low resolution. Unless DJI is able to increase it in a firmware update, I’m thinking the Spark is no good for mapping.


#9

I once succeeded mapping with Spark.
Is there any solution?(Such as correcting the exif header)


“Process exited with code 1” on Xeon E5675 x 2 with 64 GB Ram
#10

It seems that other drones have the same problem, what’s wrong? I don’t think it is caused by the memory.
) :


#11

The Mavic Pro stores 8 decimal places in the EXIF for lat/long. Makes a huge difference to resolution on the ground.


#12

I dont think it is the problem of spark, because it seems that other drones have the same problem recently.
) :