Processing error while other programs are able to run


I would already like to apologize for asking this question, since it probably is quite simple. However, I haven’t been able to solve it so far.
I have tried to process my images using WebODM, but I kept getting error notices. I have tried processing my images on Pix4D and Dronedeploy as well, which were able to make accurate maps using the same photos. Is anyone aware of what I am doing wrong?
Again, sorry for asking such a simple question, I am not that good with computers to be honest and it is my first time processing drone images.

Greetings, Matis

The drone images: heide test - Google Drive

And the code:

[INFO] Initializing ODM - Wed Nov 10 17:06:43 2021
[INFO] ==============
[INFO] auto_boundary: False
[INFO] boundary: {}
[INFO] build_overviews: False
[INFO] camera_lens: auto
[INFO] cameras: {}
[INFO] cog: True
[INFO] copy_to: None
[INFO] crop: 3
[INFO] debug: False
[INFO] dem_decimation: 1
[INFO] dem_euclidean_map: False
[INFO] dem_gapfill_steps: 3
[INFO] dem_resolution: 5
[INFO] depthmap_resolution: 640
[INFO] dsm: True
[INFO] dtm: False
[INFO] end_with: odm_postprocess
[INFO] fast_orthophoto: False
[INFO] feature_quality: high
[INFO] feature_type: sift
[INFO] force_gps: False
[INFO] gcp: None
[INFO] geo: None
[INFO] gps_accuracy: 10
[INFO] ignore_gsd: False
[INFO] matcher_distance: 0
[INFO] matcher_neighbors: 8
[INFO] matcher_type: flann
[INFO] max_concurrency: 8
[INFO] merge: all
[INFO] mesh_octree_depth: 11
[INFO] mesh_size: 200000
[INFO] min_num_features: 8000
[INFO] name: f6361dd9-507b-4ae6-8199-75f6939d5e19
[INFO] optimize_disk_space: False
[INFO] orthophoto_compression: DEFLATE
[INFO] orthophoto_cutline: False
[INFO] orthophoto_kmz: False
[INFO] orthophoto_no_tiled: False
[INFO] orthophoto_png: False
[INFO] orthophoto_resolution: 5
[INFO] pc_classify: False
[INFO] pc_csv: False
[INFO] pc_ept: True
[INFO] pc_filter: 2.5
[INFO] pc_geometric: False
[INFO] pc_las: False
[INFO] pc_quality: medium
[INFO] pc_rectify: False
[INFO] pc_sample: 0
[INFO] pc_tile: False
[INFO] primary_band: auto
[INFO] project_path: C:\WebODM\resources\app\apps\NodeODM\data
[INFO] radiometric_calibration: none
[INFO] rerun: None
[INFO] rerun_all: False
[INFO] rerun_from: [‘odm_postprocess’]
[INFO] resize_to: 2048
[INFO] skip_3dmodel: False
[INFO] skip_band_alignment: False
[INFO] skip_report: False
[INFO] sm_cluster: None
[INFO] smrf_scalar: 1.25
[INFO] smrf_slope: 0.15
[INFO] smrf_threshold: 0.5
[INFO] smrf_window: 18.0
[INFO] split: 999999
[INFO] split_image_groups: None
[INFO] split_overlap: 150
[INFO] texturing_data_term: gmi
[INFO] texturing_keep_unseen_faces: False
[INFO] texturing_outlier_removal_type: gauss_clamping
[INFO] texturing_skip_global_seam_leveling: False
[INFO] texturing_skip_local_seam_leveling: False
[INFO] texturing_tone_mapping: none
[INFO] tiles: False
[INFO] time: False
[INFO] use_3dmesh: False
[INFO] use_exif: False
[INFO] use_fixed_camera_params: False
[INFO] use_hybrid_bundle_adjustment: False
[INFO] verbose: False
[INFO] ==============
[INFO] Running dataset stage
[INFO] Loading dataset from: C:\WebODM\resources\app\apps\NodeODM\data\f6361dd9-507b-4ae6-8199-75f6939d5e19\images
[INFO] Loading images database: C:\WebODM\resources\app\apps\NodeODM\data\f6361dd9-507b-4ae6-8199-75f6939d5e19\images.json
[INFO] Found 244 usable images
[INFO] Coordinates file already exist: C:\WebODM\resources\app\apps\NodeODM\data\f6361dd9-507b-4ae6-8199-75f6939d5e19\odm_georeferencing\coords.txt
[INFO] Model geo file already exist: C:\WebODM\resources\app\apps\NodeODM\data\f6361dd9-507b-4ae6-8199-75f6939d5e19\odm_georeferencing\odm_georeferencing_model_geo.txt
[INFO] Parsing SRS header: WGS84 UTM 31N
[INFO] Finished dataset stage
[INFO] Running split stage
[INFO] Normal dataset, will process all at once.
[INFO] Finished split stage
[INFO] Running merge stage
[INFO] Normal dataset, nothing to merge.
[INFO] Finished merge stage
[INFO] Running opensfm stage
[WARNING] C:\WebODM\resources\app\apps\NodeODM\data\f6361dd9-507b-4ae6-8199-75f6939d5e19\opensfm\image_list.txt already exists, not rerunning OpenSfM setup
[WARNING] Detect features already done: C:\WebODM\resources\app\apps\NodeODM\data\f6361dd9-507b-4ae6-8199-75f6939d5e19\opensfm\features exists
[WARNING] Match features already done: C:\WebODM\resources\app\apps\NodeODM\data\f6361dd9-507b-4ae6-8199-75f6939d5e19\opensfm\matches exists
[WARNING] Found a valid OpenSfM tracks file in: C:\WebODM\resources\app\apps\NodeODM\data\f6361dd9-507b-4ae6-8199-75f6939d5e19\opensfm\tracks.csv
[WARNING] Found a valid OpenSfM reconstruction file in: C:\WebODM\resources\app\apps\NodeODM\data\f6361dd9-507b-4ae6-8199-75f6939d5e19\opensfm\reconstruction.json
[INFO] Already extracted cameras
[INFO] Export reconstruction stats
[WARNING] Found existing reconstruction stats C:\WebODM\resources\app\apps\NodeODM\data\f6361dd9-507b-4ae6-8199-75f6939d5e19\opensfm\stats\stats.json
[WARNING] Will skip exporting C:\WebODM\resources\app\apps\NodeODM\data\f6361dd9-507b-4ae6-8199-75f6939d5e19\opensfm\reconstruction.geocoords.json
[INFO] Undistorting C:\WebODM\resources\app\apps\NodeODM\data\f6361dd9-507b-4ae6-8199-75f6939d5e19\opensfm …
[WARNING] Already undistorted (nominal)
[WARNING] Found a valid OpenSfM NVM reconstruction file in: C:\WebODM\resources\app\apps\NodeODM\data\f6361dd9-507b-4ae6-8199-75f6939d5e19\opensfm\undistorted/reconstruction.nvm
[INFO] Finished opensfm stage
[INFO] Running openmvs stage
[WARNING] Found a valid OpenMVS reconstruction file in: C:\WebODM\resources\app\apps\NodeODM\data\f6361dd9-507b-4ae6-8199-75f6939d5e19\opensfm\undistorted\openmvs\scene_dense_dense_filtered.ply
[INFO] Finished openmvs stage
[INFO] Running odm_filterpoints stage
[WARNING] Found a valid point cloud file in: C:\WebODM\resources\app\apps\NodeODM\data\f6361dd9-507b-4ae6-8199-75f6939d5e19\odm_filterpoints\point_cloud.ply
[INFO] Finished odm_filterpoints stage
[INFO] Running odm_meshing stage
[INFO] Writing ODM Mesh file in: C:\WebODM\resources\app\apps\NodeODM\data\f6361dd9-507b-4ae6-8199-75f6939d5e19\odm_meshing\odm_mesh.ply
[INFO] running “C:\WebODM\resources\app\apps\ODM\SuperBuild\install\bin\PoissonRecon” --in “C:\WebODM\resources\app\apps\NodeODM\data\f6361dd9-507b-4ae6-8199-75f6939d5e19\odm_filterpoints\point_cloud.ply” --out “C:\WebODM\resources\app\apps\NodeODM\data\f6361dd9-507b-4ae6-8199-75f6939d5e19\odm_meshing\odm_mesh.dirty.ply” --depth 11 --pointWeight 4.0 --samplesPerNode 1.0 --threads 7 --maxMemory 2 --bType 2 --linearFit
[WARNING] PoissonRecon failed with 3 threads, let’s retry with 1…
[INFO] running “C:\WebODM\resources\app\apps\ODM\SuperBuild\install\bin\PoissonRecon” --in “C:\WebODM\resources\app\apps\NodeODM\data\f6361dd9-507b-4ae6-8199-75f6939d5e19\odm_filterpoints\point_cloud.ply” --out “C:\WebODM\resources\app\apps\NodeODM\data\f6361dd9-507b-4ae6-8199-75f6939d5e19\odm_meshing\odm_mesh.dirty.ply” --depth 11 --pointWeight 4.0 --samplesPerNode 1.0 --threads 3 --maxMemory 2 --bType 2 --linearFit
[WARNING] Child returned 3221226505
[WARNING] PoissonRecon failed with 1 threads, let’s retry with 0…
[INFO] running “C:\WebODM\resources\app\apps\ODM\SuperBuild\install\bin\PoissonRecon” --in “C:\WebODM\resources\app\apps\NodeODM\data\f6361dd9-507b-4ae6-8199-75f6939d5e19\odm_filterpoints\point_cloud.ply” --out “C:\WebODM\resources\app\apps\NodeODM\data\f6361dd9-507b-4ae6-8199-75f6939d5e19\odm_meshing\odm_mesh.dirty.ply” --depth 11 --pointWeight 4.0 --samplesPerNode 1.0 --threads 1 --maxMemory 2 --bType 2 --linearFit
[WARNING] Child returned 3221226505
[INFO] running “C:\WebODM\resources\app\apps\ODM\SuperBuild\install\bin\OpenMVS\ReconstructMesh” -i “C:\WebODM\resources\app\apps\NodeODM\data\f6361dd9-507b-4ae6-8199-75f6939d5e19\odm_meshing\odm_mesh.dirty.ply” -o “C:\WebODM\resources\app\apps\NodeODM\data\f6361dd9-507b-4ae6-8199-75f6939d5e19\odm_meshing\odm_mesh.ply” --remove-spikes 0 --remove-spurious 20 --smooth 0 --target-face-num 400000
===== Dumping Info for Geeks (developers need this to fix bugs) =====
Child returned 1
Traceback (most recent call last):
File “C:\WebODM\resources\app\apps\ODM\stages\”, line 94, in execute
File “C:\WebODM\resources\app\apps\ODM\opendm\”, line 347, in run
File “C:\WebODM\resources\app\apps\ODM\opendm\”, line 347, in run
File “C:\WebODM\resources\app\apps\ODM\opendm\”, line 347, in run
[Previous line repeated 3 more times]
File “C:\WebODM\resources\app\apps\ODM\opendm\”, line 328, in run
self.process(self.args, outputs)
File “C:\WebODM\resources\app\apps\ODM\stages\”, line 24, in process
File “C:\WebODM\resources\app\apps\ODM\opendm\”, line 207, in screened_poisson_reconstruction’"{reconstructmesh}" -i “{infile}” ’
File “C:\WebODM\resources\app\apps\ODM\opendm\”, line 106, in run
raise SubprocessException(“Child returned {}”.format(retcode), retcode)
opendm.system.SubprocessException: Child returned 1

===== Done, human-readable information to follow… =====

[ERROR] Uh oh! Processing stopped because of strange values in the reconstruction. This is often a sign that the input data has some issues or the software cannot deal with it. Have you followed best practices for data acquisition? See Flying Tips — OpenDroneMap 2.6.4 documentation

1 Like


Sorry you’re having trouble with this dataset.

Usually a Child Returned 1 means an Out-Of-Memory condition.

Could you provide a bit more detail about the machine you’re running this on?

Also, I’ll check the data in a bit to see if anything is funky.

For the meanwhile, and to satisfy my curiousity, could you try adding the --auto-boundary option and lowering --feature-quality and --pc-quality to medium or low?

1 Like

I am running it using a Lenovo Notebook. Processor: AMD Ryzen 7 3700U (2.30 GHz) and 12 gb installed RAM (9.88 usable).
I have tried your suggestions and will report the results once the program has finished processing. Do these setting changes lower the quality of the end result as well?
Thank you so much for your help.

1 Like

Yes, they will, but it may or may not be significant for your use case. You’ll be able to determine when you get results.

–auto-boundary does not reduce quality, though. It just filters and constrains the reconstruction area a bit.

Created on: 11/10/2021, 5:34:43 PM
Processing Node: Lightning - UAV4Geo (manual)
Options: auto-boundary: true, cog: true, crop: 0, debug: true, dem-gapfill-steps: 4, dem-resolution: 1, dsm: true, dtm: true, matcher-neighbors: 16, mesh-size: 300000, min-num-features: 16000, orthophoto-resolution: 1, pc-classify: true, pc-ept: true, pc-filter: 1, pc-geometric: true, pc-quality: high, resize-to: -1, use-3dmesh: true, verbose: true
Average GSD: 2.11 cm
Area: 35,048.04 m²
Reconstructed Points: 23,395,360

Came out pretty decent!

Ah, I have found the issue. I was running GIS programs at the same time, so it probably was too much for my laptop. When I closed the other programs it worked just fine. Thank you for your help :slight_smile:

1 Like

If you have an SSD with a lot of space, you could try increasing your pagefile size.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.