Process exited with code 1 - Child Returned 137


#1

Hi,

Have looked through all the similar posts, but can’t seem to get it to process!

This is the link to the data I am trying to process

https://dronemapper.com/sample_data/ - its the red rocks set.

I’ve installed it on my desktop and given it varying CPU cores - tried 1 to 3
Also tried upping the RAM from the original 2gb to 24gb, upped the swap file to 4096mb.

I did manage to get a smaller set going the monument data set from agisoft, but I figured since other programs can do this set, this should be able to ?

Heres the output

`
[INFO] Running ODM Georeferencing Cell - Finished
[INFO] Running ODM DEM Cell
[INFO] Classify: False
[INFO] Create DSM: True
[INFO] Create DTM: False
[INFO] DEM input file /var/www/data/ff61ded2-409a-4391-abef-fbad2d249880/odm_georeferencing/odm_georeferenced_model.laz found: True
[WARNING] Cannot calculate GSD, using requested resolution of 5.0
[INFO] Creating …/var/www/data/ff61ded2-409a-4391-abef-fbad2d249880/odm_dem/dsm_r0.025 [idw] from 1 files
[DEBUG] running pdal pipeline -i /tmp/tmpCsqAfJ.json > /dev/null 2>&1
[INFO] Creating …/var/www/data/ff61ded2-409a-4391-abef-fbad2d249880/odm_dem/dsm_r0.05 [idw] from 1 files
[DEBUG] running pdal pipeline -i /tmp/tmp5m6Gqj.json > /dev/null 2>&1
[INFO] Creating …/var/www/data/ff61ded2-409a-4391-abef-fbad2d249880/odm_dem/dsm_r0.1 [idw] from 1 files
[DEBUG] running pdal pipeline -i /tmp/tmpjkSJaK.json > /dev/null 2>&1
Traceback (most recent call last):
File “/code/run.py”, line 47, in

plasm.execute(niter=1)
File “/code/scripts/odm_dem.py”, line 112, in process

max_workers=args.max_concurrency
File “/code/opendm/dem/commands.py”, line 38, in create_dems

fouts = list(e.map(create_dem_for_radius, radius))
File “/usr/local/lib/python2.7/dist-packages/loky/process_executor.py”, line 786, in _chain_from_iterable_of_lists

for element in iterable:
File “/usr/local/lib/python2.7/dist-packages/loky/_base.py”, line 589, in result_iterator

yield future.result()
File “/usr/local/lib/python2.7/dist-packages/loky/_base.py”, line 433, in result

return self.__get_result()
File “/usr/local/lib/python2.7/dist-packages/loky/_base.py”, line 381, in __get_result

raise self._exception
Exception
:
Child returned 137

This was caused directly by
“”"
Traceback (most recent call last):
File “/usr/local/lib/python2.7/dist-packages/loky/process_executor.py”, line 410, in _process_worker
r = call_item.fn(*call_item.args, **call_item.kwargs)
File “/usr/local/lib/python2.7/dist-packages/loky/process_executor.py”, line 329, in _process_chunk
return [fn(*args) for args in chunk]
File “/code/opendm/dem/commands.py”, line 92, in create_dem
pdal.run_pipeline(json, verbose=verbose)
File “/code/opendm/dem/pdal.py”, line 232, in run_pipeline
out = system.run(’ ‘.join(cmd) + ’ > /dev/null 2>&1’)
File “/code/opendm/system.py”, line 34, in run
raise Exception(“Child returned {}”.format(retcode))
Exception: Child returned 137
“”"`

I did also have these custom options enabled.

Options: mesh-octree-depth: 7, resize-to: 1500, rerun-from: dataset, dsm: true, max-concurrency: 1


#2

Set --dem-resolution to 4x your orthophoto résolution, e.g. 20. A soon arriving update will automatically calculate this for you.


#3

Thanks for the reply, where abouts do i find what the current orthophoto resolution is ?


#4

Also try to decrease --max-concurrency (start with 1 to be on the safe side).