Problems installing WebODM on new install of Ubuntu 22.04

I’ve followed the Linux installation directions for WebODM but they appear to be outdated.

  1. sudo apt update
  2. curl …
    curl was not already installed so I did a manual install
  3. sh
  4. sudo apt install -y git python python-pip
    This command did not install pip.
    so I manually installed pip
  5. docker-compose was not installed so I had to install it.
    it reports a build version of “unknown”
  6. git clone worked
  7. cd WebODM worked
  8. ./ start -------------- this crashed

Starting WebODM…

Using the following environment:

Host: localhost
Port: 8000
Media directory: appmedia
Postgres DB directory: dbdata
SSL key:
SSL certificate:
SSL insecure port redirect: 80
Celery Broker: redis://broker
Default Nodes: 1

Make sure to issue a ./ down if you decide to change the environment.

docker-compose -f docker-compose.yml -f docker-compose.nodeodm.yml up --scale node-odm=1
Traceback (most recent call last):
File “/usr/lib/python3/dist-packages/urllib3/”, line 699, in urlopen
httplib_response = self._make_request(
File “/usr/lib/python3/dist-packages/urllib3/”, line 394, in _make_request
conn.request(method, url, **httplib_request_kw)
File “/usr/lib/python3.10/http/”, line 1282, in request
self._send_request(method, url, body, headers, encode_chunked)
File “/usr/lib/python3.10/http/”, line 1328, in _send_request
self.endheaders(body, encode_chunked=encode_chunked)
File “/usr/lib/python3.10/http/”, line 1277, in endheaders
self._send_output(message_body, encode_chunked=encode_chunked)
File “/usr/lib/python3.10/http/”, line 1037, in _send_output
File “/usr/lib/python3.10/http/”, line 975, in send
File “/usr/lib/python3/dist-packages/docker/transport/”, line 30, in connect
PermissionError: [Errno 13] Permission denied

During handling of the above exception, another exception occurred:

with more pages as well.

Suggestions? thanks

If I remember correctly there should a bit about adding your user to the docker group.

1 Like

sudo usermod -aG docker $USER

1 Like

so i added my user name and tried it again but got the same exact error messages.

I tried $./ update and that spewed lots of errors as well.

1 Like

I just read in another thread that I have to start webodm as sudo

sudo ./ start

You do not, if you are in the Docker group (and in general running things as root is not a great thing).

Group membership changes are only reflected after login or reboot, so do that if you have not yet.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.