Problems after webodm update

Hello all…

I have this problem after updating. I have tried different browsers.

Mattias,

Can you tell us the browser(s), platform, and version of WebODM?

I briefly experieced the same with the Docker version, but subsequent updates have resolved that behavior.

Sorry…

Ubuntu server install, tried chrome and firefox. Webodm 1.9.11

1 Like

And you’ve done the webodm.sh update step to ensure that you’re fully up to date?

Correct

1 Like

Are your projects backed up?

If so, you could uninstall/reinstall WebODM in Docker.

Alternatively, you could try using the Administration panel to remove the Projects/Tasks and see if you can re-add new Projects/Tasks and have it behave properly.

If not, I think a full remove/reinstall would be an option.

Open the Chrome developer Console (F12) and see if you get any errors when you trigger the crash?

1 Like

main-6bf8410ab6d65132987b.js:22 TypeError: Cannot read properties of undefined (reading ‘length’)
at eval (TaskView.js:67)
at n.value (TaskView.js:67)
at Da (main-6bf8410ab6d65132987b.js:22)
at Za (main-6bf8410ab6d65132987b.js:22)
at gs (main-6bf8410ab6d65132987b.js:22)
at gl (main-6bf8410ab6d65132987b.js:22)
at _l (main-6bf8410ab6d65132987b.js:22)
at ll (main-6bf8410ab6d65132987b.js:22)
at main-6bf8410ab6d65132987b.js:22
at e.unstable_runWithPriority (main-6bf8410ab6d65132987b.js:30)

1 Like

Mm, looks like the webpack build did not go correctly when you updated. Try to rebuild and check for any error messages during the update/build commands.

1 Like