Problem with convergence on Inter-tidal habitat map, Any ideas for help?

Hi all,

I’ve got a mapping project that I cannot get WebODM to run properly. The project consists of 405 images captured using a DJI Mavic 2 Pro.

No matter what settings I’ve tried, WebODM hangs up when run it and i’m forced to close the package down through Task Manager. I have run this same project through Pix4D and the output is very good. Given this result I think the images and metadata with them is acceptable for Ortho and 3d model generation.

Please note that I have been able to run small samples of the images from this flight plant (up to about 70) through to completion in WebODM but the results are not good with model results generating multiple intersecting surface planes, see these screen shots for example:

Here is a link to the flight plan images (as many as I can fit in that account) for anyone that would like to have a go at processing them in WebODM:

Dropbox - File Deleted)

Or the full package through drive here:

I feel like there must be some setting tweaks that would help get these images to converge and map properly but its been beyond me so far.

I’m also happy to share the process log file from the task shown in the images above if that would be of help but i’m technically challenged today as to how I can add that txt file to this post (suggestions welcome, feeling like a NOOB).

Thanks in advance for any help you all can provide!

Hey @Kirk :hand:could you try to set --matcher-distance and --matcher-neighbors both to 0?

You could just upload the task output in a .txt file saved on your google drive.

Thank you,

.txt file uploaded to the shared Drive folder just now.

I’ll have to wait till i’m at home tonight to try running this task with your suggested settings.


Gave it a try with matcher-distance and matcher-neighbors` both set to 0.

The task ran to completion this time which is an improvement but i’m still getting some errors in the model, see screen shots below.

I’ve uploaded the task output log into the shared google drive linked above.

Any other tweaks that might help?

1 Like

Try also decreasing min-num-features by a factor of 2 while doubling resize-to

Will do.

Really appreciate your quick help!

3d model really unravled with those settings changes:

This flight covers an inter-tidal sand flat with very low profile oyster reef bases. the elevation profile is very narrow from about -1 to - 2.5 meters.

Is there anyway to force the model output to conform to that elevation plane or trim the output to that elevation band? Just thinking outside the box, no idea what this would entail on the modeling/processing side.


I think i’ll just run several partial data sets and see how that goes. I can get all the info I need that way. I’ll re-fly this site again soon on a sunny day (rather than with cloud cover like in this case) and will see how that data set processes.

I had some very similar issues on a dataset that was also an inter-tidal mud flat. In the end I brought the data into CloudCompare to trim out the obviously erroneous points.
As you say, it would be really nice to set a value for expected heights, or maximum actual gradient, to give the depth mapping a bit of manual help.

1 Like

I am getting some curious errors at the MVE stage for this. Can you try the --use-opensfm-dense flag?

I have given this a try but it locks up and hangs so I have not been able to get the process to run to completion.

I’ve just flown and captured another data set that is of a seawall and foreshore area (290 images) and it has processed with this same type of errors. I’m loading that data set into pix4d now to see if it will run in that environment. The Myall dataset worked great in Pix4d

Not sure whats going on here.

It’s failing for me on MVE. Have you tried the OpenSfM flag above?

Yes I have and when running it with that option selected the task hangs and I have to manually shut it down.

Sorry the forum automatically removed my quote of your post on this which would have made it clear that I had tried it.

1 Like