Problem uploading high number of images

Hello, I’m running WEBODM from the WEBODM Manager 1.3.0 with a Laptop with 30 GB RAM and core i7 processor. When I work with less than 100 images the platform works fine, but when I try with more than 400 the uploading never ends or the project never starts. Could someone help me solve this issue?

Buen dia Luis valdez, yo tengo exactamente el mismo problema, incluso yo trabajo en un servidor, asi que no creo que sea un problema de recursos de computo, es problema del software, tengo aqui alrededor de 2 semanas esperando que alguien pueda aportar una solucion, pero aun nada, sabes algo al respecto?


Gracias, he escrito a support de MasseranoLabs, espero que me confirmen lo dicho por ti o me den una solución.

When you say “the uploading never ends or the project never starts.”, do you mean that the upload never completes? Or processing starts but never ends? Can you copy paste your console output and task output here so that we can take a look?

1 Like

Disculpa luis, si logras que funcione el software si no es molestia podrias compartir conmigo la solucion a el problema, de igual forma si encuentro resultados te notifico.


I had the same problem, I was trying to upload 800 pics (7mb each). My work around was to upload batches of 200 pics at the time. Select the pics, then open, then wait a few minutes and webodm will refresh the page showing the number of selected pics, then keep adding images “Select Images and GCP” until all the pics are selected. Cheers.

I had the same problem when uploading more than 200 pics. I noticed that safari was refreshing since it was using a lot of RAM during the process. Therefore, I tried with firefox and the process was done without any further problem. Maybe it is a problem with your web browser.

@Katrography is the issue that you were running into? Did you resolve it?

Possibly. I think the root cause of my issue was the “Fast Ortho” option that I was using. I was able to get 214 images to upload successfully in Chrome with the default settings, but could not get it with the “fast ortho” settings.

Locally, I would get similar errors to this issue: Process exited with code 1 · Issue #122 · OpenDroneMap/WebODM · GitHub. So maybe it was a RAM allocation issue… not sure. I haven’t had time to dive back into. Ill try to end of this week.

Cool. Are you Fast Ortho for speed or for potential quality? If the latter, set mesh-solver-divide and mesh-octree-depth to 5 or 6 and you should get pretty good orthos.

Hi. I am trying to make an ortofoto whit 420 pics. I try before whit 10 pics and all ok. But whit 420 the clock never star. I have 2 days waiting the uploading and no results yet. See the screenshot. What is the correct process for 420 pics? Thanks, Gandhi.

same here… exacly same with 2000 img.

works well with 250 images

I successfully processed more than 1000 images in a single task with webodm.

I did face such issues on my laptop initially…but later i tried on a system with 65 Gb RAM, the process was completed. However, webodm used to hang after opening a task(…i believe the console logs take time to load).

Relevant: Very long lag in browser responding to user input in the webODM interface. · Issue #483 · OpenDroneMap/WebODM · GitHub

I solved this problem by resizing the photos in browser. It’s the last option when you pull down the resize list.
The other solution was not to resize at all.
Both of these worked for me.