Problem removing WebODM in order to reinstall, Ubuntu 16.04 VM


Hi Folks,

I’ve had a problem logging in to WebODM, so decided to nuke it and re-pull from Git. I’ve followed the basic instructions of deleting the WebODM folder then the ‘git’ command from the readme on github.

This worked but when running “./ start” it just restarted the existing images. Tried renaming the WebODM folder and to no avail.

Any idea how to fully remove WebODM?

I’m running Virtualbox VM on Windows 7. The VM is Ubuntu 16.04, fully updated.



Images are stored in a docker volume (it’s a bit… complicated, I’ll spare the details but if you’re curious you can read more about them here

To remove all tasks/images (this will nuke everything), simply do:

./ down
docker volume rm $(docker volume ls)
./ start


Thank you Piero. Now you mention it I think I’d already worked that out months ago… but then totally forgot it again! Actually pretty sure I put it in a word document… must check my notes before posting! Thanks for your time.