Problem getting WebODM to run properly (was previously working)

#1

I am relatively new to WebODM/ODM, so forgive my questioning if it seems a little naive.

I recently set up and have been running WebODM on a Windows 10 running Hyper-V. The VM MobyLinuxVM is configured with 20GB RAM and about 64GB disk storage. I had everything working well and was able to put WebODM through its paces from loading datasets all the steps through meshing, texturing, etc, to get 3D object models, orthomosaic maps.

More recently (it seems to be after I ran ./webodm update (which brought it to App Version 0.82), I have been unable to run any jobs. It seems to want to ‘Set a processing node’. Upon clicking this link I get the message:

There are no usable processing nodes. Make sure that at least one processing node is reachable and that you have granted the current user sufficient permissions to view the processing node (by going to Administration – Processing Nodes – Select Node – Object Permissions – Add User/Group and check CAN VIEW PROCESSING NODE). If you are bringing a node back online, it will take about 30 seconds for WebODM to recognize it.

Under Administration there is no subcategory Processing Nodes.

There is separately a Processing Nodes category. Within this option I can select the existing (I assume default) node. Selecting it displays:

node-odm-1:3000 seems to be offline.

I can edit the node and set the object permissions so that my account CAN VIEW PROCESSING NODE, as well as the other available permissions.

This does not seem to accomplish anything. I have tried stopping and restarting WebODM. I have added and configured a new processing node. Still the same results.

Any thoughts/strategies/suggestions?

Thanks

0 Likes

#2

Do you have any errors when starting the service? Have you tried running the update again?

0 Likes

#3

I don’t have any errors when starting the service (that is, when I run ./webodm.sh start from PowerShell). When WebODM is first launched a window briefly pops up with statuses lighting up in green indicating docker, git, python, pip, and docker-compose are OK and that the elements (worker, webapp, broker, db) as OK. That window immediately closes. I’m sure there’s a log file, though I don’t know the specific path/file name so I can locate it.

I will try running update once more.

0 Likes

#4

I ran the ./webodm.sh update.

All seems to be fine on starting up webodm.

I log in, create a project and then import a set of images from the Datasets group of the ODM Community page. The particular dataset I imported was from Brighton Beach dataset which has exif info.

The import process is run and displays a status of Completed.

This is the logging info from the terminal window:

broker | 1:M 16 Apr 2019 06:00:18.100 * 100 changes in 300 seconds. Saving…
broker | 1:M 16 Apr 2019 06:00:18.101 * Background saving started by pid 15
broker | 15:C 16 Apr 2019 06:00:18.115 * DB saved on disk
broker | 15:C 16 Apr 2019 06:00:18.115 * RDB: 0 MB of memory used by copy-on-write
broker | 1:M 16 Apr 2019 06:00:18.201 * Background saving terminated with success
worker | INFO Extracted all.zip for Task [Task of 2019-04-16T06:00:14.217Z] (b8dd17f5-1417-4c9b-9c10-0da0e30cf6b7)
worker | [2019-04-16 06:00:19,232: INFO/ForkPoolWorker-1] Extracted all.zip for Task [Task of 2019-04-16T06:00:14.217Z] (b8dd17f5-1417-4c9b-9c10-0da0e30cf6b7)
worker | INFO Cleaning up OAM datastore for task b8dd17f5-1417-4c9b-9c10-0da0e30cf6b7
worker | [2019-04-16 06:00:19,244: INFO/ForkPoolWorker-1] Cleaning up OAM datastore for task b8dd17f5-1417-4c9b-9c10-0da0e30cf6b7

However, when I open the Tasks I see the following:

Created on: 4/16/2019, 2:00:17 AM
Processing Node: - (manual)
An orthophoto could not be generated. To generate one, make sure GPS information is embedded in the EXIF tags of your images, or use a Ground Control Points (GCP) file.

and the items Image Resize / Upload, Load Dataset, Structure From Motion / MVS, Meshing, Texturing, Georeferencing, DEM, Orthophoto, Post Processing all have checkmarks next to them, as if they were all processed.

There are no buttons like Start or Restart; there is only Download Assets, View 3D Model and Delete.

0 Likes

#5

I am pleased to report that all seems to be working well.

@ITWarrior: Your suggestion of running the update was likely the right thing to do.

Separately, the other issue I had was importing/running files. WebODM kept looking for zip files and that never work (files would import and immediately, the status was reported as “Completed”) so there was never any task that could be Started/Restarted. The fix for this problem is not to click and select from the “Select Images and GCP” pull-down (which only seem to want zip files), but rather to click directly on the “Select Images and GCP” label without engaging the pull-down menu. I would then be prompted to select all the individual image files. Once the files are selected, they get imported and all the expected processing beginnings running.

Hopefully, this will help somebody else if they come across this problem.

0 Likes