Pixelated orthophoto

Hello.

I tried to generate an orthophoto using a collection of 230 frames taken at a low altitude flight (3 meters above ground). If I try the code below…

docker run -it --rm \
    -v "$(pwd)/images:/code/images"  \
    -v "$(pwd)/odm_orthophoto:/code/odm_orthophoto"  \  
    opendronemap/opendronemap  \
    --orthophoto-resolution 0.01

…I get a blurry and pixelated orthophoto like this one:

image

For some reason, if I subset the collection to, for example, 33 frames, and run the same code as above, the orthophoto generated seems to be OK, like this one:

image

Any idea of what am I doing wrong?

Answering my own question.

The flag --ignore-gsd fixed it, so the code ended like this:

docker run -it --rm \
    -v "$(pwd)/images:/code/images"  \
    -v "$(pwd)/odm_orthophoto:/code/odm_orthophoto"  \  
    opendronemap/opendronemap  \
    --orthophoto-resolution 0.01 \
    --ignore-gsd
3 Likes

For anybody curious about the Run Time Parameter:

–ignore-gsd
Ignore Ground Sampling Distance (GSD). GSD caps the
maximum resolution of image outputs and resizes images
when necessary, resulting in faster processing and
lower memory usage. Since GSD is an estimate,
sometimes ignoring it can result in slightly better
image output quality.

1 Like