PIL.Image.DecompressionBombError: Image size exceeds limit of pixels

That’s an awesome trick!

I was trying to attach the console to the docker session and then vi the Python file and… Yeah, I got nowhere haha

1 Like

Yeah, I’ve had to do it a lot here on the edges of the possible… .

I think you have to do a docker commit as well.

1 Like

Hi Both,

Just want to inform you again, initially referring GitHub Code tried to create Docker Image few times but every time the process got stuck. Later, when I simply tried to create DSM using Docker Image from DockerHub had this pixel limit issue.

To summarize, in order to ahead need your support for the following:

  • Provide with updated Docker Image wherein Pixel Limit is not an issue
  • Details Step & Code to create Docker Image

Hi,

Any luck or update?

Hi Saijin,

Any update?

Sorry, Vivek. I’ve been unable to figure this out within Docker.

Can you check and advise, the pre-requisites to run DockerFile for ODM?

Installation and Getting Started — OpenDroneMap 2.6.3 documentation

Hi,

Found the solution and the following are its details:

  1. In order to create Docker Image, need a machine with 16G memory and not 8G memory
  2. Next commented the last line in Dockerfile “ENTRYPOINT [“python3”, “/code/run.py”]” and initiated Docker Container.

There are still some more issues, fixing them one by one. Once done will share the complete solution details

1 Like

Hi,

Initially, I tried to generate DSM using Docker Container with memory limit set as 32 GB, but it failed with an error:

[ERROR] Whoops! You ran out of memory! Add more RAM to your computer, if you’re using docker configure it to use more memory, for WSL2 make use of .wslconfig (https://docs.microsoft.com/en-us/windows/wsl/wsl-config#configure-global-options-with-wslconfig), resize your images, lower the quality settings or process the images using a cloud provider (e.g. https://webodm.net).

Later, had increased the memory limit to 64 GB but again failed with the same error. Can anyone please tell, what is an issue here?

It sounds like you’re still running out of memory. If you’re processing images that are larger than 175MP each, that doesn’t sound too unusual.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.