Pictures Won't Upload

I run a Mavic 3 m, I have been using web ODM to process all of the maps I have made so far. I recently started running into problems with uploading the pictures to process them (the progress bar would come up then it would never load). In the past I have restarted my computer, and Web ODM. And then it would work fine. But now the progress bar comes up starts loading then says " exceeded max retries (10)". Thanks to everyone that responds to these questions. It has helped me a lot!
I use the Mavic 3 M for data collection, and a MacBook Pro (14-inch, 2021) with 16g ram for processing

1 Like

Can you tell us what node you’re sending the images to, what your internet connection is like ( works well), and what your Docker settings show for resources?
Quick Start Guide and sign in

It could be this, now fixed, bug: Update by ezeakeal · Pull Request #1312 · OpenDroneMap/WebODM · GitHub

1 Like

Thanks for your reply! I am sending them to my local processing node, no internet (node-odm-1). My docker settings are: CPUs=6, Memory=14gb, Swap=2.5gb, Virtual disk limit=224gb.

1 Like

Thanks for your help! I must admit, I don’t know how to use the code from GitHub, do I copy and past into Docker or just push updates on my odm manager? I’m wondering now, I think I had updated it just before I had this problem. Thanks again!

1 Like

navigate to where you installed webodm with a shell (like git-bash), and execute the following, one by one, allowing each to complete before entering the next one.

./ stop
./ update
./ start

it will update with latest version from github


I have also recently had this problem and same error. For me, it appears it could have been a lack of free disk space causing it.

Yesterday I had a 40-gb dataset, also Mavic 3, and it took me 4 attempts before it would upload to Lightning. Right before the 4th attempt one thing I did differently was clear up disk space. I went from 10gb free to 70gb free.

Sure enough, same thing tonight with another 40gb dataset, which would not upload with only 30gb free disk. Once I free’d up disk space, it has now uploaded successfully.


Thanks for your help! I Think I did the same thing when I used my webODM manager and pressed the update button. I installed webODM with the installer, (I don’t know code). :face_with_peeking_eye:
And now it works! I was processing a map while I was typing!!

1 Like

Yes I have ran into the same problem. My computer only has ~500gb. I found a great way to remedy the problem though. Buy an internal hard drive reader and a hard drive. The whole setup costs about $60 from amazon. Some things to learn from my mistakes… be sure to get a usb-c or something fast, make sure you have a good connection in the reader if you use an ssd and it gets disconnected it will corrupt most or all of your data. I store all my map pictures on there and all my zips from odm. :muscle:

1 Like

Hi, I wonder if anyone else is having problems uploading pictures? After updating in odm manager I processed about 3-4 maps (all multispectral). Then on the fifth one the pictures would not upload. My computer was getting full so I saved my zips. Then, deleted the files off of web odm. And restarted. I have about 200g now, but the pictures will not upload whatsoever. the progress bar stays at 0%. Any help would be appreciated! Thanks!

1 Like

Please restart your machine and try again.

Sorry, the long response time. Thanks Saijin_Naib for your response! I don’t have internet at home which. May be causing some of the problems. But here is what I have found so far. I can usually get the program to map if I either restart the program and the computer. Or if I switch processing nodes. (From lighting back to my local node). This has almost always worked, it just means I have to go to a place with internet to be able to connect to the lightning node.
Also to note, I usually run into problems after a process a couple large datasets. A few of my fields are around 700-1600 pictures. I usually run out of space and have to delete the pictures get my zip files and restart web odm to clear the memory.

P.S. I love the work everyone has done, I really appreciate open source projects. I wish I could help out more. Thanks again!

1 Like

Yeah, you’re absolutely going way beyond the capabilities of your Mac with datasets that large, hence the crash and need to reboot.

Also, your Docker volume might need to be expanded, which is why you need to clear out projects.

Lightning sounds like it would be better if you had internet at home…

Do you have access to a more powerful machine at home?

No, I don’t have access to a larger machine. I’ve been contemplating building one. Maybe down the road. I know this is off subject but what would be the most cost effective way to do that. If I could make a server computer that was connected to a home intranet, that would be sweet. Yeah my computer only has 500gb. As far as docker goes I have it set to around 200 gb for hard drive space. I built an external hard drive that I want to use. I’ll leave all the pictures on it and process them from the hard drive. But I haven’t been able to give it a good try with all the uploading problems so far.

P.S. I haven’t tried processing the 1600 picture dataset I do half of it, and stitch it together with QGIS.

1 Like

Give this topic a read:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.