Patchy Multispectral Imagery

I’m having some issues with my multispectral imagery coming out ‘patchy’, as if the bands aren’t reading in properly in certain areas.

The drone used was a Phantom 4 Multispectral RTK.

Parameters were:

*feature-quality: ultra,
*force-gps: true,
*ignore-gsd: true,
*orthophoto-compression: NONE,
*pc-quality: ultra, pc-rectify: true,
*radiometric-calibration: camera+sun,
*texturing-data-term: area,
*texturing-skip-global-seam-leveling: true,
*verbose: true

The images come out like this:

*WebODM Display:
image

*ArcPro Display:
image

I did about 6 datasets this way and all of them came out the same. Overlap should be ~80/80 for this area, if not more.

Here’s the report:

2 Likes

Can you remove all parameters except radiometric calibration, feature quality, point cloud quality, verbose/debug, and maybe try increasing matcher neighbors and min num features by 25%

1 Like

I will give it a shot next time I have access to the computer! thanks for the quick reply, figured I was probably overthinking some of those parameters.

1 Like

There are certainly use-cases for every parameter, otherwise Piero drops them.

That being said, I think the easiest thing is to start from a known-safe baseline and experiment from there. What that baseline is looks a bit different from person to person, dataset to dataset.

Once we’re on a “safe” baseline, it will make further troubleshooting a bit less mystifying for both of us :slight_smile:

well I tried it with your recommended parameters (from the previous post), and also again with these parameters:

“build-overviews: true, debug: true, dsm: true, dtm: true, feature-quality: ultra, min-num-features: 12000, radiometric-calibration: camera+sun, texturing-skip-global-seam-leveling: true, verbose: true, rerun-from: dataset”

and both times gave me the exact same patchy output unfortunately. The images process clearly in Agisoft Metashape - so I don’t think the issue is coming from the images (there is 10300 total images). any other recommendations on what to try? I’m also happy to answer any questions you may have about my setup.

image

1 Like

Can you share a small contiguous subset of the data on dronedb.app?

I’m really not sure what is going on here. I’m sorry!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.