OSError: [Errno 16] Device or resource busy: '/code/smvs'


#1

Hi all,

I was trying to run the ODM using docker image. Following is the command I entered :

docker run -it --rm -v “/home/ODM_input_datsets:/code/images” -v “$(pwd)/odm_orthophoto:/code/odm_orthophoto” -v “$(pwd)/opensfm:/code/opensfm” -v “$(pwd)/odm_georeferencing:/code/odm_georeferencing” -v “$(pwd)/odm_meshing:/code/odm_meshing” -v “$(pwd)/odm_texturing:/code/odm_texturing” -v “$(pwd)/gcp_list.txt:/code/gcp_list.txt” -v “$(pwd)/smvs:/code/smvs” opendronemap/opendronemap --depthmap-resolution 1000 --opensfm-depthmap-min-consistent-views 2 --opensfm-depthmap-method “BRUTE_FORCE” --matcher-distance 400 --ignore-gsd --mesh-point-weight 0 --texturing-nadir-weight 32 --use-3dmesh --crop 0 --orthophoto-resolution 2.57 --mesh-size 1000000 --texturing-skip-visibility-test --texturing-data-term “area” --time --min-num-features 12000 --mesh-octree-depth 12 --resize-to -1

I deleted previous docker images and built a new one after the latest release…

However, it returns an error as below : (copied the last few lines)



[INFO] Running ODM OpenSfM Cell - Finished
[INFO] Running SMVS Cell
Traceback (most recent call last):
File “/code/run.py”, line 47, in
plasm.execute(niter=1)
File “/code/scripts/smvs.py”, line 63, in process
shutil.rmtree(tree.smvs)
File “/usr/lib/python2.7/shutil.py”, line 256, in rmtree
onerror(os.rmdir, path, sys.exc_info())
File “/usr/lib/python2.7/shutil.py”, line 254, in rmtree
os.rmdir(path)
OSError: [Errno 16] Device or resource busy: ‘/code/smvs’

The same dataset ran successfully on native installation using run.sh script…but problem comes when using docker.
Could someone please help.

Thank you.


Using GCP's in Open drone map
#2

Also experiencing this, using opendronemap/opendronemap:0.4.0

the approach defined here worked: https://github.com/OpenDroneMap/OpenDroneMap/issues/902


#3

Thank you so much!! It worked for me too.


#4

by the way, for convenience the solution from github issues was:

docker run -ti --rm -v /path/to/project:/datasets/code opendronemap/opendronemap --project-path /datasets