Orthophoto file sizes

Why are the orthophoto file sizes so large? 1.5GB is a typical size, with 1.3cm pixels, ~400 photos. What I’m doing isn’t small, but it sure isn’t huge, either. Processing these photos on other software produces comparable TIFFs that are maybe 10% of the size. Is there any way to get smaller file sizes?

You can adjust the compression method.

https://docs.opendronemap.org/arguments/orthophoto-compression/#orthophoto-compression

We might want to investigate possibly adding different compression parameters or presets in the future. LZMA should compress better than DEFLATE, but doesn’t enjoy the same wide compatibility and has a slightly higher processor load for compression and decompression.

2 Likes

Okay. I tried the jpeg compression option but when I download the asset as GeoTIFF(Raw) the file size is still 1.2GB. Downloading as GeoTIFF(JPEG) produces an error saying that it can’t work out how to assign 4 colour channels to 3 bands.

And when I download the GeoTIFF(Raw) the alpha channel is set to black and the transparent background option doesn’t work in AutoCAD.

1 Like

I believe it’s the lack of compression in the output exports. I’ve opened Add compression to GeoTIFF export outputs · Issue #1099 · OpenDroneMap/WebODM · GitHub to track this improvement.

Strange that you can’t export to GeoTIFF (JPEG), can you share your Raw UTM GeoTIFF?

The compression methods in the task options will always apply to the Raw UTM GeoTIFF, but not for the other export formats.

2 Likes

Here’s the GeoTIFF. This is the only one I could get to work.

1 Like

Can you also share the one that didn’t work? You should still be able to export it to GeoTIFF (RAW) leaving the default UTM projection. :pray: it would help troubleshoot the problem of exporting it to JPG. (Or is this the one that didn’t work?)

1 Like

Sorry for slow replies, busy day. I deleted most of the files that weren’t useful. Give me some time and I’ll sort through the settings I’ve tried and makes sure I’m getting you the right file(s).

1 Like

Also, the one I gave you was the one that was good.

2 Likes

Okay, so the file I shared with you previously was created using the deflate compression option (which is the default:
image

Here is a file created with the Jpeg compression option:
image
but downloaded using the GeoTIFF(Raw) option:
image
The background isn’t transparent, it’s just black.

Attempting to download with GeoTIFF (RGB) produces this error:
image

Downloading as jpeg works mostly fine (file here, though produces a weird black/white background effect. In this case the file size is 23MB, which is obviously much better, but it’s not georeferenced and we need the georeferencing.

2 Likes

Thanks! This helps. Note that JPEGs do not have transparency so they will always have a white/black background. Use GeoTIFF or PNG if you need transparency.

1 Like