Orthomosaic not covering surveyed area

I have tried to capture a barley field, but using ODM the resulting orthophoto does not cover the surveyed area.

The photos and gcp list is available here

Here is a screenshot from QGIS showing the resulting orthophoto and the camera positions from the drone.
orthophoto + photos

I used a DJI Phantom 4, and I programmed the flight with PIX4D capture, with the following settings
-Polygon
-Front overlap 75%
-Side overlap 60%
-Altitude 30m
-Camera angle 90 deg
-Look at grid center no

Roughly 400 × 300 m were covered. This resulted in 292 photos. I have 4 GCP’s.

I used the high quality orthophoto preset.

The resulting orthomosaic only covers very little (mostly the center) of the surveyed area. I have tried different variations of settings in ODM without it drastically changing the result.
Up until now i have not experienced this issue.
I suspect it is because my photos are too similar and featureless, but I am unsure.

If that is the case, do you have any suggestions on mission planning to get photos that are useful for creating a orthophoto.

1 Like

Welcome! Sorry you’ve had trouble.

I’d see if you could refly with 65% sidelap, 85deg gimbal, and a higher flight height. I had great fortune at 120m for Agricultural Field Survey.

Thank you for your suggestions.

Id like to keep the GSD below 2 cm/pixel, so 120 m altitude might not be a good option with my current camera, but I will try to program the flight with greater side overlap, and the gimbal at 85 deg.

Do you suggest doing both a 90 deg and 85 deg flight?

1 Like

No I don’t think you need one survey pass at nadir.

What is the highest you can go and meet your GSD requirement?

At 45 m my cameras average GSD is 1.98 cm/px according top P4D Capture.

1 Like

That’s a pretty signifcant increase in flight height from 30m. I think it will help a lot.

image

Options: cog: true, crop: 0, debug: true, dem-resolution: 1, dsm: true, orthophoto-resolution: 1, pc-classify: true, pc-geometric: true, pc-quality: high, use-3dmesh: true, verbose: true

I did a bit better, but it looks like many camera positions were not usable and did not get put into the reconstruction.
Report_kim_8109.pdf (7.8 MB)


image

Options: cog: true, crop: 0, debug: true, dem-resolution: 1, dsm: true, matcher-distance: 0, matcher-neighbors: 0, min-num-features: 32000, orthophoto-resolution: 1, pc-classify: true, pc-geometric: true, pc-quality: high, use-3dmesh: true, verbose: true

This did better yet, but still not great. I think you really would benefit from what we talked about above.
Report_Kim_pre-processed_tweaked.pdf (8.5 MB)

1 Like

Thank you very much.
I might not revisit, this specific field as it only was an auxiliary task to do the orthomosaic.
But I will definitely try out your sugggestions next time I approach a similar project.

2 Likes

I had a look at one of the images in full resolution, and noticed that the image quality deteriorated significantly as you look further off-axis.
I suspect that with the relatively large blurry almost featureless areas covering a significant part of the images, it’s going to be very hard to find matching points across several images, so that stitching will fail.

Were these taken with the aperture wide open? Generally the best image quality occurs when you stop down a few stops, at f5.6 or 8, rather than f2.8.
Of course you may need to adjust ISO in order to keep the shutter speed reasonable.

Yeah, generally diffraction is minimized somewhere close to the middle of the aperture range of your particular lens. You can test to ensure, but closest to midpoint aperture works well enough most times.

I only have a Phantom 4 with fixed aperture at my disposal, but I will certainly take this suggestion in to consideration.

2 Likes