Ortho photos are extremely grainy

I am new to WebODM and relatively new to drone mapping. The ortho photos seem to come out really grainy. Is there something that I could possibly being doing wrong?

Please share a screenshot, raw data, and processing settings. Bonus points for giving details on your hardware configuration and installation process.

1 Like

Welcome! As Stephen said, not much actionable in your first post, but all very easy to fix!

I’m going to bet that a few parameter tweaks will get you sorted :slight_smile:

1 Like

what would be the best way to share the raw data and processing settings?

You can share the data to dronedb.app or another Cloud Service provider, and you can copy/paste your processing settings here, if you like.

build-overviews
Enable
camera-lens

cameras (json)

cog
Enable
crop (positive float)
3
debug
Enable
dem-decimation (positive integer)
1
dem-euclidean-map
Enable
dem-gapfill-steps (positive integer)
3
dem-resolution (float)
5
depthmap-resolution (positive float)
640
dsm
Enable
dtm
Enable
end-with

fast-orthophoto
Enable
feature-quality

feature-type

force-gps
Enable
gps-accuracy (positive float)
10
ignore-gsd
Enable
matcher-distance (integer)
0
matcher-neighbors (integer)
8
matcher-type

max-concurrency (positive integer)
16
merge

mesh-octree-depth (positive integer)
11
mesh-size (positive integer)
200000
min-num-features (integer)
8000
optimize-disk-space
Enable
orthophoto-compression

orthophoto-cutline
Enable
orthophoto-kmz
Enable
orthophoto-no-tiled
Enable
orthophoto-png
Enable
orthophoto-resolution (float > 0.0)
5
pc-classify
Enable
pc-csv
Enable
pc-ept
Enable
pc-filter (positive float)
2.5
pc-geometric
Enable
pc-las
Enable
pc-quality

pc-rectify
Enable
pc-sample (positive float)
0
pc-tile
Enable
primary-band (string)
auto
radiometric-calibration

rerun-from

resize-to (integer)
2048
skip-3dmodel
Enable
skip-band-alignment
Enable
skip-report
Enable
sm-cluster (string)
None
smrf-scalar (positive float)
1.25
smrf-slope (positive float)
0.15
smrf-threshold (positive float)
0.5
smrf-window (positive float)
18
split (positive integer)
999999
split-overlap (positive integer)
150
texturing-data-term

texturing-keep-unseen-faces
Enable
texturing-outlier-removal-type

texturing-skip-global-seam-leveling
Enable
texturing-skip-local-seam-leveling
Enable
texturing-tone-mapping

tiles
Enable
use-3dmesh
Enable
use-exif
Enable
use-fixed-camera-params
Enable
use-hybrid-bundle-adjustment
Enable
verbose
Enable

image

1 Like

image
purchased the WEBODM windows installer

Try not using --fast-orthophoto, and try upping --orthophoto-resolution to 1.0.

I’m also not clear if you’ve really enabled every parameter as you have listed. Is that the case?

Yes, those parameters were copied directly from the Ortho settings.
I have adjusted the resolution and re-running now…
I will update you on the results.

1 Like

That seemed to do the trick. Thanks.

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.