Ortho Photo not aligning with DTM Survey

I have run a survey using a P4P RTK, in RTK Mode, with the Base Station set up on an arbitrary point, i.e. not over a known point.
I have processed the images 3 different ways, as follows;

  1. Using The default Profile without GCP’s in WebODM
  2. Using the default profile using GCP’s
  3. Using Pix4D std profile. Link to Ortho https://dileighce-my.sharepoint.com/personal/adam_dileigh_com_au/Documents/Pix4D%20ortho%20Theodore

All of these options have been overlayed on the DTM with the following outcomes;
Option 1. no GCP with default webODM Profile after an initial alignmnet of ortho to DTM you have approx 4 meter misalignment from one end of the DTM to the other. i.e. if you align common points at one end of the ortho with the DTM the other end of the ortho is approx 4m out from the common points at the other end of the DTM.

Option 2. with GCP and default ODM profile. This is reduced to 2m with the bottom of the ortho aligning as expected and the top of the ortho approx 2.0m out. GCP’s are spread out over the project fairly evenly.

Options 3. Pix4D, gives a result as expected, being after the initial shift to everything lines up with the DTM.

I do not have this issue generally with webODM so am keen to understand what is happening here. Any assistance will be greatly appreciated.

Link to photos and GCP file same as the pix4D ortho link.

1 Like

Mm, curious to see if you get improvements by turning on --force-gps in the task options.

(also, can’t access the links)

Keep an eye also on https://github.com/OpenDroneMap/ODM/pull/1106 which we’re going to merge soon.


the server is not on a https server, so that may be an issue for you, but you can select to access and ignore this. the other links should be fine. what is the error(s)?

I will also use force GPS but from memory i have done that.


Try this link. I had done something wrong with permissions. The server is hhtp no https. so try your settings, or give me the error you get.

Love the project look forward to testing it when it comes through.

pierotofy I am running it again now with the force GPS setting.
I will let you know how it goes.

i have not compared it to the DTM yet but seems to have same scaling error.
Ill let you know when i check.

Also make sure you updated ODM since we merged PR 1106. Those changes should improve results.


OK so i have run update, after some issues. I think it is working on the latest build.
is there a setting or do i just rerun the project on the default profile?

Thanks again for your assistance.

ah wow, was just reading OpenSfM flags the other day looking into what ‘—force-gps’ means. Am I reading rightly that GPSXYAccuracy and GPSZAccuracy XMP tags will be used if they exist?

just finished a 1200 image run with it ahead of this merge, gonna have to do it again :smiley:

1 Like

Yes they are used with the latest version.

so you have to check Force GPS? to use the GPSY&ZAccuracy.

If you have a GCP, yes.

1 Like

OK then i had tried to run the update and it appeared to work, but i have re-run the project with the same result as before i updated. is there a docker command to check the version of my webodm server?

Alternatively i will run it using my windows install on my laptop tonight to compare results.

Sorted by using my calibrated json file from a successful project. do not usually have this issue, however i usually shoot some non NDIR shots.
I am also running it again with no json file and gps-accuracy: .02. Which is the reported accuarcy in my exif data, to see how this goes.

Love your work Piero! I would love to contribute in any way i can.


Here’s some ideas for different ways to support the project: https://github.com/OpenDroneMap/WebODM/#support-the-project


Thanks Peiro
over night i also processed with no json file and with the GPS-accuracy .02 and that worked great too.
the ortho is on par with pix4D