Ortho photo is good when build a part of the area, bad when build all the whole area

Hi everyone,

I am using webodm to build ortho photo for solar power plant.
Because the plant is so large, i flew the drone twice to take picture on 2 parts of plant.
If i run webodm for each separate part, the result is good but for the whole plant (including 2 parts), the bottom part of part 1 will be bad.

My WebODM:

  • API Version: 2.2.0
  • Engine: odm
  • Engine version: 2.7.2

Settings:

auto-boundary: true, dsm: true, feature-quality: ultra, feature-type: hahog, ignore-gsd: true, min-num-features: 18000, optimize-disk-space: true, pc-quality: low

The input and result is saved here:
https://drive.google.com/drive/folders/1uH4DxAe79Sc53QnVPUCV2HThVbq6jnHM?usp=sharing

What should i do to fix it?

Thank you in advance for any help

1 Like

It comes out ok with the below settings.

813 images 01:21:38
|Options:|auto-boundary: true, dem-resolution: 2.0, dsm: true, dtm: true, feature-quality: ultra, gps-accuracy: 8, mesh-octree-depth: 12, mesh-size: 250000, min-num-features: 12000, orthophoto-resolution: 2, pc-filter: 5, pc-geometric: true, pc-quality: ultra, resize-to: -1, smrf-threshold: 2.5, use-3dmesh: true|
|Average GSD:|10.64 cm|
|Area:|363,157.78 m²|
|Reconstructed Points:|44,394,029|

2 Likes

It works well.
Thank you. You saved my day!

Could you tell me what was wrong and what is the key point to fix or improve it?

1 Like

Point cloud quality would be important. The images were quite small, without a lot of detail to start with, so I used ultra to retain as much of that detail as possible.
pc_geometric may have helped, as the PV array is not dissimilar to rows of buildings.
It is rarely useful to use ignore-gsd, and it often causes a crash, but that doesn’t appear to have been a problem here.

2 Likes

I understood. Thank you for your help.

1 Like