ODM "Strange error code" when making an ortho

Hi everyone,

I’ve searched for similar issues others have had and not found a response that matches this problem so far. I am trying to make a decent sized orthomosaic and after several hours this happened:

===== Dumping Info for Geeks (developers need this to fix bugs) =====
Child returned 3221226505
Traceback (most recent call last):
File “D:\WebODM\resources\app\apps\ODM\stages\odm_app.py”, line 89, in execute
File “D:\WebODM\resources\app\apps\ODM\opendm\types.py”, line 340, in run
File “D:\WebODM\resources\app\apps\ODM\opendm\types.py”, line 340, in run
File “D:\WebODM\resources\app\apps\ODM\opendm\types.py”, line 340, in run
[Previous line repeated 1 more time]
File “D:\WebODM\resources\app\apps\ODM\opendm\types.py”, line 321, in run
self.process(self.args, outputs)
File “D:\WebODM\resources\app\apps\ODM\stages\openmvs.py”, line 76, in process
system.run(’%s “%s” %s’ % (context.omvs_densify_path,
File “D:\WebODM\resources\app\apps\ODM\opendm\system.py”, line 106, in run
raise SubprocessException(“Child returned {}”.format(retcode), retcode)
opendm.system.SubprocessException: Child returned 3221226505

===== Done, human-readable information to follow... =====

[ERROR]   The program exited with a strange error code. Please report it at https://community.opendronemap.org

I am running this on my home computer, the similar topics suggested were run on cloud clusters, so I assume this is a different cause.

Any help would be great, I’m hoping to migrate totally to this system and away from Drone Deploy. The test map that I managed to stitch worked well and I like it.

1 Like


What are your system specs?

Also, what processing parameters are you using?

These are the system specs:

OS Name Microsoft Windows 10 Home
Version 10.0.19042 Build 19042
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name MSI
System Manufacturer Micro-Star International Co., Ltd.
System Model GS63VR 7RF
System Type x64-based PC
System SKU 16K2.3
Processor Intel(R) Core™ i7-7700HQ CPU @ 2.80GHz, 2801 Mhz, 4 Core(s), 8 Logical Processor(s)
BIOS Version/Date American Megatrends Inc. E16K2IMS.30E, 8/03/2017
SMBIOS Version 3.0
Embedded Controller Version 255.255
BaseBoard Manufacturer Micro-Star International Co., Ltd.
BaseBoard Product MS-16K2
BaseBoard Version REV:1.0
Platform Role Mobile
Secure Boot State Off
PCR7 Configuration Elevation Required to View
Windows Directory C:\WINDOWS
System Directory C:\WINDOWS\system32
Boot Device \Device\HarddiskVolume1
Locale Australia
Hardware Abstraction Layer Version = 10.0.19041.964
User Name MSI\Nathan
Time Zone E. Australia Standard Time
Installed Physical Memory (RAM) 16.0 GB
Total Physical Memory 15.9 GB
Available Physical Memory 4.50 GB
Total Virtual Memory 29.9 GB
Available Virtual Memory 12.0 GB
Page File Space 14.0 GB

I tried the DTM processing option for this one as that is what I needed at the time


1 Like

You may have run out of free physical memory.

How many images and what megapixel resolution for them?

1998 images at 17.5GB total, 4000x2000

1 Like

Yeah, you may be well above the RAM limit with that.

Have you played with split/merge workflows yet?

Didn’t know they existed!

1 Like


Would running it all from a dedicated portable hard drive also solve the problem?

No, sadly not. You’re not short on storage, you’re short on Memory/RAM.

If you have a large/fast flashdrive, Windows 10 can let you use it as a ReadyBoost drive.

Brilliant! Cheers for that. I’ll see how I go with the flash drive situation until I can buy a new computer

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.