ODM keeps running out of RAM

I have a dataset of 4,577 images. My system currently has a 64 gb ram. Every time I run odm, during the final stage of merging, I received a “you are out of RAM” error. I have also setup a .wslconfig file,. I was able to previously process a 100 images. Any solutions?
This is the command I’m executing.
docker run -ti --rm -v datasets e:/datasets:/datasets --gpus all opendronemap/odm:gpu --project-path /datasets --split=400 --feature-quality=low

This is the .wslconfig file:
image

1 Like

You’ll need more RAM than a desktop system can provide to process a dataset that big unless you break it up in chunks and merge. I routinely go over 256GB on a 4,000 image job.

1 Like

Orthophoto takes lots of ram but a pointcloud a lot less.

I just make a pointcloud and make a photo from that in CloudCompare.

3 Likes

Is breaking it up different from using --split flag? Cause I am doing that, but the issue still persists

1 Like

No, that’s what they are referring to, so you’re already well down the right path.

Could you tell us a bit about your split and split-overlap settings? What resolution are the images?

You might be able to get by with resizing the images during Task creation, especially if you don’t have a certain GSD requirement.

Sorry for the late reply, so for --split flag I used 400 and for --split-overlap I kept default settings.
The image dimensions are 5472 X 3468 pixels. I believe GSD will be important for our use case.
What are your suggestions?Cause I keep getting ram finished error:

1 Like

Set your split to maybe 200 or so and try again?

I’ve tested with upto a 1000 images without split and it has worked successfully. Will a split of 200 really make a difference?

1 Like

Quite likely. Unfortunately, a split of 400 only applies to the submodel starting place and doesn’t include the area of submodel overlap. So a split of 400, depending on distance of overlap and density of photos could easily exceed 1000 images per submodel.

It’s probably the most confusing aspect of split-merge.

2 Likes

Thanks, I did not know that. I’ll try it out with a lower split.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.