ODM Installation Ubuntu 18.04

Hello, I was struggling with the installation of ODM for Ubuntu 18.04, moreover, I achieved the installation in a WSL on windows 10.

“”" NOTE: Enter with root privileges “sudo su” till the end of the installation"

The steps are the following:

  1. first install ODM from this tutorial, https://github.com/OpenDroneMap/ODM#native-install-ubuntu-1604, start in the part that says " Native Install (Ubuntu 16.04)", but with the following changes:
  • Extract all the ODM files inside a folder with the following path “/code”, this folder will be in the root directory of your ubuntu (next to use, bin,home,etc)

  • Go to the /code folder and Instead of “bash configure.sh install” use “bash configure_18_04.sh install”, you should have this file in the ODM folder, using this command will return you some errors in some python dependencies, this is Okay because there is some transition of Python 2 to Python 3, so lots of packages from Python 2 are not being updated, some of this incompatibilities are produced due to “gdal-bin, libgdal_dev, python-gdal and liblas-bin”, this is Okay but be sure that “gdal-bin and libgdal_dev” are installed, you can do this by a simple import test or try to reinstall the the packages with “pip” (not pip3 because most of the packages of ODM are for python2 as far as I know)

  • the “settings.yaml” project path has to be set to “/code”

  • then extract the example folder that is mentioned in “ODM”, it is the aunkerman example, extract it inside “/code”

  • Finally run your simulation as the example mentions it (inside the /code folder “./run.sh …”)

the “bash” configuration is the most important folder so if you can keep track of the log output and check all the errors it shows during the installation, if you have

If you have some pytz problem or osgeo problem as I had. just install:

  • pip install pytz gdal

If you have some “boost errors” install the following:

  • sudo apt-get install libboost-all-dev

I also found some vtk errors with “/usr/bin/vtk” and “libvtkRenderingPythonTkWidgets.so”, what I did:

  • sudo update-alternatives --install /usr/bin/vtk vtk /usr/bin/vtk6 10
  • sudo ln -s /usr/lib/python2.7/dist-packages/vtk/libvtkRenderingPythonTkWidgets.x86_64-linux-gnu.so /usr/lib/x86_64-linux-gnu/libvtkRenderingPythonTkWidgets.so

source of this one= " https://github.com/autowarefoundation/autoware/issues/795 "

I also had some problems with LAS Compilation, I followed the compilation instructions of:
https://liblas.org/compilation.html#using-unix-makefiles-on-linux
Just follow the instructions to compile " Using “Unix Makefiles” on Linux", follow the instructions including “make install command”

Remember to use “bash configure_18_04.sh reinstall” each time you make a change.

So, that´s it, I hope it helps and if this worked in my WSL platform I hope it works on all of you.
kind regards!

I got this result, I think is pretty good, if It can be improved I am open to ideas

image

4 Likes

Jonathan,

Thanks for your incredible detective work and contribution!

I’ve been attempting (and struggling) to do the same as you’ve done above for a while now. I’m simply way out of my league, here.

Could you please look at what I’ve collected here, and make any contributions/corrections you feel is necessary?

Oh Cool work! I only have my ubuntu 18.04 kernel, I´m not a programmer, just a curious guy, I like ODM so I tried hard to make it work, and It worked! I don´t have a graphical interface with ubuntu (but I would like an independent laptop with Ubuntu, last time I did dual boot and It crashed my windows OS), I could help you with the script for ODM in Ubuntu 18.04, kind regards.

1 Like

Please do! I used the 18.04 script bundled with LiveODM after I upgraded from 16.04LTS to 18.04LTS, but it caused my system to be in an inconsistent state with broken/held packages. So, despite it technically working, it left the system in a bad way…

I wonder what we can do to fix that.

Yeah, at the end all are the same, bu I prefer ODM, it´s not complicated, I´ll let you know when I have it, currently I´m without time.
kind regards.

1 Like

There are several methods to fix broken packages. The easiest (but not well documented) is to use Synaptic Package Manager. Use: Edit - Fix Broken Packages. Sometimes you have to run it a few times if the packages are well fubarred. It doesn’t always work, either, and does not tell you why not.

1 Like

Yep, tried Synaptic and aptitude multiple times, and the broken/held dependencies were not resolvable.

will it be straightforward installation and running if it is done on 16.04? i mean it the github specifically for 16.04?

Maybe! I didn’t have success, but I’m very bad at compiling things from source.

Hi ,
i followed your steps but i am not able to run it

the bitbucket code is in --> /home/kkaran/code
images are in --> /home/kkaran/code/images

i am trying to run run.sh from directory /home/kkaran/code
./run.sh --project-path /images

it gives me following error

[INFO] Running dataset stage
[INFO] Loading dataset from: /images/code/images
[ERROR] Not enough supported images in /images/code/images

can you suggest please where i am making mistake

Thanks and much appreciated

Should be from root of the volume, I think, not user directory

Hi ,
did not quite follow . can you please explain

thank you