ODM Cut the part of the orthophoto

Hi Guys,
i notice strange behavior and i don’t understand why they happen.

i have two render - the first one with about 500pics to check all flag and settings to have preview how the work.
the results are very good

secondly i run the main task with the same settings which contain about 2500 pics, after about 30h i get really cool results but the part of the orthophoto are missing - is clipped.
in this case on the main task i miss the top of the pic - part of road and forest. (marked at red)
they just cut the orthophoto.tif like on the left side view

my ODM settings:

docker run -ti --rm -v /home/task:/datasets/code opendronemap/odm --project-path /datasets --min-num-features 40000 --depthmap-resolution 1000 --mesh-size 400000 --mesh-octree-depth 12 --texturing-nadir-weight 20 --orthophoto-resolution 3 --verbose --crop 0 --camera-lens brown --use-hybrid-bundle-adjustment --optimize-disk-space --texturing-outlier-removal-type gauss_damping --dem-gapfill-steps 8 --texturing-data-term area --opensfm-depthmap-method BRUTE_FORCE --time

is someone who have same issue and know how to resolve it? :wink:
best regards


Hi @machinefly

Nice map!

This behavior might be caused by the forest areas wich have few distinguishable features. You should try increasing min-num-features, but note that this will result in longer processing times.

1 Like

Hi @israelbar
thanks for replay.
could that be the min-num-features be solution even they render corectly on small task and crop on the bigest and both task have the same min-num-features value?
notice that the both task are runing with min-num-features 40000 (default is 8000), is there any value that you suggest? :wink:


Sorry @machinefly, I just realice you are resizing the images. So maybe the first step is to set “resize-to” to -1, this only affects the SMF process, you will not expecience changes in the resulting orthophoto.

Alternatively you can also set to “No” in the “Resize Images” option. With this setting all input images will be affected, so you may notice changes in the resulnting assets.


I also foud this:

Regarding the min-num-features number, I guess it is possible to set it to 50000, 60000 or even 80000, and it usually works.

I hope this helps, as I’m also learning and trying to get the most of opendronemap.


1 Like

after a few another test i stuck in the same place.
i increase the min-num-features from 40k to 80k, set resize images to -1 and lift up depthmap-resolution to 1600. the results is still the same.

I prepared graphics to better illustrate the issue:

the green dots shows first group of pics (let’s call this ‘green’ group ), its 597pics.
if i render just the pics from ‘green’ group, i get the resoult like below:

but if i render the pics from group green and red (1028 pics)
then i still get this:

even if i tweek and lift up parameters of task at the finally resoult i get clipped top part of the orthophoto

1 Like

still the same problem but at the middle of the map.
when i run task with all 7k pics, after a 6 day i get:

(at the left: orthophoto vs at the right: points where the photos was taken)

Strange thing are when i run task whit some part of photos, the results are difficult.
for example:
task whit 400pics from missing part:

and task whit about 900 pics from missing part and visible part:

like we can see when the task have only small amount of pics they do good job, but if run task whit a lot fo pics they somehow missed part of dataset.

I made many combinations of parameters, the results are different, but they differ mainly in the quality of the map but not in the number of photos represented in the map.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.