ODM Cut the part of the orthophoto

Hi Guys,
i notice strange behavior and i don’t understand why they happen.

i have two render - the first one with about 500pics to check all flag and settings to have preview how the work.
the results are very good
full.PNG

secondly i run the main task with the same settings which contain about 2500 pics, after about 30h i get really cool results but the part of the orthophoto are missing - is clipped.
in this case on the main task i miss the top of the pic - part of road and forest. (marked at red)
they just cut the orthophoto.tif like on the left side view
small

my ODM settings:

docker run -ti --rm -v /home/task:/datasets/code opendronemap/odm --project-path /datasets --min-num-features 40000 --depthmap-resolution 1000 --mesh-size 400000 --mesh-octree-depth 12 --texturing-nadir-weight 20 --orthophoto-resolution 3 --verbose --crop 0 --camera-lens brown --use-hybrid-bundle-adjustment --optimize-disk-space --texturing-outlier-removal-type gauss_damping --dem-gapfill-steps 8 --texturing-data-term area --opensfm-depthmap-method BRUTE_FORCE --time

is someone who have same issue and know how to resolve it? :wink:
best regards
Pawel

2 Likes

Hi @machinefly

Nice map!

This behavior might be caused by the forest areas wich have few distinguishable features. You should try increasing min-num-features, but note that this will result in longer processing times.

1 Like

Hi @israelbar
thanks for replay.
could that be the min-num-features be solution even they render corectly on small task and crop on the bigest and both task have the same min-num-features value?
notice that the both task are runing with min-num-features 40000 (default is 8000), is there any value that you suggest? :wink:
thanks

2 Likes

Sorry @machinefly, I just realice you are resizing the images. So maybe the first step is to set “resize-to” to -1, this only affects the SMF process, you will not expecience changes in the resulting orthophoto.

Alternatively you can also set to “No” in the “Resize Images” option. With this setting all input images will be affected, so you may notice changes in the resulnting assets.

image

I also foud this:

Regarding the min-num-features number, I guess it is possible to set it to 50000, 60000 or even 80000, and it usually works.

I hope this helps, as I’m also learning and trying to get the most of opendronemap.

Saludos

1 Like

after a few another test i stuck in the same place.
i increase the min-num-features from 40k to 80k, set resize images to -1 and lift up depthmap-resolution to 1600. the results is still the same.

I prepared graphics to better illustrate the issue:
groups
the green dots shows first group of pics (let’s call this ‘green’ group ), its 597pics.
if i render just the pics from ‘green’ group, i get the resoult like below:
full.PNG

but if i render the pics from group green and red (1028 pics)
then i still get this:
odm_1+2

even if i tweek and lift up parameters of task at the finally resoult i get clipped top part of the orthophoto

1 Like