Orthorectify feature not working
ModuleNotFoundError: No module named ‘opensfm’
Can anyone help. I issued the exact docker commands as mentioned
I am fairly new to docker as well as ODM

1 Like


Sorry to read you’re having trouble with docker.

May I ask what platform you’re on?

It sounds like the docker image isn’t complete, somehow.

1 Like

I am currently using docker Desktop on Windows

1 Like

Hmm… Did you purchase the Easy Installer for Windows from UAV4Geo?

If so, would you mind emailing [email protected] with your order number (MYS-XXXXXXXXXX) so we can further assist you?

If not, would you mind trying to re-follow the instructions for the Docker install to see if it will properly re-fetch the Docker images it needs?

Please post any screenshots or logs of what happens when you get a chance to re-try it.

Firstly I ran the command :
docker run -ti --rm -v /home/youruser/datasets:/datasets opendronemap/odm --project-path /datasets project

Then :
docker run -ti --rm -v /home/youruser/datasets:/datasets --entrypoint /code/contrib/orthorectify/orthorectify.py opendronemap/odm /datasets/project

I ran the above command in Ubuntu as well but got the same error

Traceback (most recent call last):
File “/code/contrib/orthorectify/orthorectify.py”, line 15, in
from opensfm import dataset
ModuleNotFoundError: No module named ‘opensfm’

1 Like

Can anyone tell what am i doing wrong.

Might be a bug, probably line 7 of the script does not point to /code and/or SuperBuild/install/bin which is where the opensfm module lives.

Open a pull request if you find a way to fix it? :pray:

1 Like

I was able to fix that and was able to reference it to the opensfm path. Thanks for the help
But was stuck at another error. Can someone help

After running the reconstruction I ran the following code
python orthorectify.py D:\Inviz\Pollen\datasets5\project

Processing 307 images
Reading DEM: D:\Inviz\Pollen\datasets5\project\odm_dem/dsm.tif
DEM Minimum: 195.78526
DEM has a CRS: EPSG:32611
DEM offset: (314132.0, 5128218.0)
DEM dimensions: 5580x4954 pixels
Traceback (most recent call last):
File “orthorectify.py”, line 149, in
udata = dataset.UndistortedDataSet(dataset.DataSet(os.path.join(dataset_path, “opensfm”)))
TypeError: init() missing 1 required positional argument: ‘undistorted_data_path’

1 Like

Hello pierotofy
I was able to solve the above error and get the orthorectified image.
I had a doubt of why it was containing 4 bands while the image to be rectified has only one band

1 Like

Nice!! Would you be able to share how you fixed it and possibly open a pull request on GitHub? :pray:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.