ODM build native failed


#1

Hi
After running sudo bash configure.sh install, I’ve got

– The imported target “vtkRenderingPythonTkWidgets” references the file
“/usr/lib/x86_64-linux-gnu/libvtkRenderingPythonTkWidgets.so”
but this file does not exist. Possible reasons include:

  • The file was deleted, renamed, or moved to another location.
  • An install or uninstall procedure did not complete successfully.
  • The installation package was faulty and contained
    “/usr/lib/cmake/vtk-6.2/VTKTargets.cmake”
    but not all the files it references.
    CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
    Please set them or make sure they are set and tested correctly in the CMake files:
    EXIV2_LIBRARY
    linked by target “odm_extract_utm” in directory /home/david/OpenDroneMap/modules/odm_extract_utm
    ============================================
    so, there’s two problems.
  1. libvtkRenderingPythonTkWidgets.so is associated with package libvtk-dev, that I have installed. Tried reinstalling it, but no luck.

  2. The CMake error. How do you “set and test correctly in the CMake files”? I did see the exiv2_library not found. Link broken, and changed the url appropiately, without luck

Any ideas on how to solve this problems will be much appreciated

Thanks


#2

Mm, it could be due to a lot of problems :slight_smile: just to verify, are you on Ubuntu 16.04? Also, have you tried using the docker version?


#3

Thanks for the reply Piero. Yes, I’m on ubuntu 16.04. The error appeared when I tried to install it on my laptop. I gave up on it, and then tried to install it on AWS-EC2 (ubuntu 16.04 instance).

It all went well until it run setup.py bdist_wheel for gippy … It remained there for about 4 hours. I cancelled with Ctrl-C. The last lines of the process said
Collecting https://github.com/gipit/gippy/archive/1.0.0.zip
Downloading https://github.com/gipit/gippy/archive/1.0.0.zip
| 1.5MB 14.6MB/s
Requirement already up-to-date: psutil in /usr/local/lib/python2.7/dist-packages (5.4.8)
Requirement already satisfied, skipping upgrade: numpy>=1.9 in /usr/local/lib/python2.7/dist-packages (from gippy==1.0.0) (1.15.4)
Building wheels for collected packages: gippy
Running setup.py bdist_wheel for gippy … \

Ater I cancelled, it continued with

Compiling SuperBuild
– No build type selected, default to Release
– SuperBuild files will be downloaded to: /home/ubuntu/ODM/SuperBuild/download
– SuperBuild source files will be extracted to: /home/ubuntu/ODM/SuperBuild/src
– SuperBuild source files will be installed to: /home/ubuntu/ODM/SuperBuild/install
– SuperBuild binary files will be located to: /home/ubuntu/ODM/SuperBuild/build
– OpenCV 2.4.11 not found — Adding internal version

and hangs again in
[ 58%] Performing build step for ‘pcl’
[ 1%] Building CXX object common/CMakeFiles/pcl_common.dir/src/range_image.cpp.o

after a couple of hours I cancelled with Ctrl-C again and it says
common/CMakeFiles/pcl_common.dir/build.make:422: recipe for target ‘common/CMakeFiles/pcl_common.dir/src/range_image.cpp.o’ failed
make[5]: *** [common/CMakeFiles/pcl_common.dir/src/range_image.cpp.o] Interrupt
CMakeFiles/Makefile2:117: recipe for target ‘common/CMakeFiles/pcl_common.dir/all’ failed
make[4]: *** [common/CMakeFiles/pcl_common.dir/all] Interrupt
Makefile:160: recipe for target ‘all’ failed
make[3]: *** [all] Interrupt
CMakeFiles/pcl.dir/build.make:113: recipe for target ‘pcl/stamp/pcl-build’ failed
make[2]: *** [pcl/stamp/pcl-build] Interrupt
CMakeFiles/Makefile2:327: recipe for target ‘CMakeFiles/pcl.dir/all’ failed
make[1]: *** [CMakeFiles/pcl.dir/all] Interrupt
Makefile:83: recipe for target ‘all’ failed
make: *** [all] Interrupt

I gave up on ODM installation on AWS and succeeded installing WebODM on AWS :slight_smile: And now I have another question I opened in the WebODM section. Thanks!