ODM 101 - help I cant get past step 1 - what am I doing wrong?

Hi I need basics help please … Im trying to stitch my files together … but I simply cannot get past this first step.

I’m getting : process exited with code -01 … after only 2 seconds
there must be somthing im leaving out ? but what ?
I tried stitching both the 41Mb Raw files and the 11Mb Jpeg files …

fly shoot :
DJI Mavic 2, height 60Meters, shoot every 4 seconds at 10 kms/h,
Using Litchi app to fly the route.

my equip:
Ive installed docker, gis and ODM, all seem to be correctly instaled acourding to Terminal. im on apple macbook pro, 2,2GHz IntelCorei7, 16GB internal, with loads of disk space.

link to my files :


console file is also in dropbox

The data is fine, though next time you should consider using more overlap. You also have a photo missing from near the centre (Map tab):
https://dashboard.aerosurvey.co.nz/public.cgi?S=427&T=9f8103a7-34f4-47ad-853b-717f6a1444df

How are you uploading the files and triggering the job? The fact that it dies instantly is unusual and suggests a config or service error rather than running out of resources or an issue with the files.

Hi ITWarrior. thank you so much for responding … I really appreciate your reply

This is what i am doing …
Launch ‘Docker’ and make sure it is started and running …
Docker triggers WebODm to open a browser page (Firefox) and then a login page for Dashboard - WebODM … I login and can see all the projects/Tasks that ive attempted to stitch … there are several … and none of them have worked … it must be something i’m iether not doing or doing wrong.

Start a new task … click on ‘Select Images & GCP’ … (what is GCP?) … this opens access to my computer files and I select a few files in sequence …
then click ‘Review’ … i leave all other settings as is …default.
‘Review’ becomes ‘Start Processing’ … click start
files upload
‘Running’ … the timer ticks over …
after a while … ‘Completed’

at this point mostly i get error code 01
sometimes ill get a single picture processed

im flying at 60 meters … should I fly higher ? … could this be the problem ?

Your files aren’t the problem, I was able to process them fine. After you upload the files and before you start the task, can you take a screenshot?

It sounds like you might only be uploading one file.

Hi Ben

so … im selecting files by using dashboard Web-ODM … the files are all on my computer. the system sees the files and clearly appears to upload them, screen grabs to show attached

I found what i think is an GCP file … ive now placed it in the drop box with all the resource pics. its called ‘aRedDot.txt’ it was eamiled from the Litchi App and i thnk is the flight route document.

also … I cannot find a break in the pic numbers to see if there is a missing picture.

thank you for your help on this … really appreciate you giving your time.

35 57 42 35

To double check - you’re ONLY uploading the JPGs, right? Don’t upload any text files, and try to run that.

Hi Ben
yes I had only uploaded the jpegs … no text file as I had no idea what a GCP was …
… now there is a text file uploaded … it worked … but I need to know that this is not just a once off …
note : I shoot with Litchi, and the text file is emailed out of that app.

In fact I did run the process with the text file (which I uploaded to dropbox) and that did work … the files processed and stitched together.
The times (before) that I ran the process without that text file … it did not process.
so I assume now that it needs the text file (the flight path / route / GCP)

I will now try process all the other orchards with thier ‘text file’ and see if that is a common soultion.
I will also do as you say, and run a process again on that same RedDot Orchard, without the text file.

ill keep you posted.

once again thank you for being there …

paul

ok … that was disapointing. ran 2 new projects … with text file … process exited code 1
:frowning:

Hi Ben
I have just processed the 2 new projects without the text files … and it worked
… how random ! … ive really done nothing different from the first set of processing i tried.

… so strange.

1 Like