Not processing all Multispectral Bands

I am trying to process 1310 images from my Mecasense Micasense rededge camera. For some reason, it’s not processing all bands. Thanks in advance.

[INFO] Fast orthophoto is turned on, automatically setting --skip-3dmodel
[INFO] DTM is turned on, automatically turning on point cloud classification
[INFO] Initializing ODM - Sat Dec 19 08:24:34 2020
[INFO] ==============
[INFO] build_overviews: False
[INFO] camera_lens: auto
[INFO] cameras: {‘micasense rededge 1280 960 brown 1.1458 blue’: {‘projection_type’: ‘brown’, ‘width’: 1280, ‘height’: 960, ‘focal_x’: 1.1589626608202381, ‘focal_y’: 1.1589626608202381, ‘c_x’: 0.026384410787813894, ‘c_y’: 0.005679101753941108, ‘k1’: -0.07340217251236827, ‘k2’: 0.07753744027240361, ‘p1’: 0.0009980679310383678, ‘p2’: -0.0012260105725874844, ‘k3’: 0.03545901380030076}, ‘micasense rededge 1280 960 brown 1.1458 green’: {‘projection_type’: ‘brown’, ‘width’: 1280, ‘height’: 960, ‘focal_x’: 1.1573314223704725, ‘focal_y’: 1.1573314223704725, ‘c_x’: 0.003890121046317773, ‘c_y’: 0.002109008131436674, ‘k1’: -0.07486889193429358, ‘k2’: 0.08252170048864226, ‘p1’: 0.0009666814441764056, ‘p2’: -0.0010383507298765099, ‘k3’: 0.03552783181362917}, ‘micasense rededge 1280 960 brown 1.1458 rededge’: {‘projection_type’: ‘brown’, ‘width’: 1280, ‘height’: 960, ‘focal_x’: 1.1597642212804677, ‘focal_y’: 1.1597642212804677, ‘c_x’: -0.003525154610966184, ‘c_y’: 0.008145481915915163, ‘k1’: -0.07737891237197571, ‘k2’: 0.07689628713429875, ‘p1’: 0.00021171960763726925, ‘p2’: -0.0015645923530165457, ‘k3’: 0.034235592463022144}, ‘micasense rededge 1280 960 brown 1.1458 nir’: {‘projection_type’: ‘brown’, ‘width’: 1280, ‘height’: 960, ‘focal_x’: 1.159903942931982, ‘focal_y’: 1.159903942931982, ‘c_x’: 0.021440182651411517, ‘c_y’: 0.011810288927861026, ‘k1’: -0.06046732901782252, ‘k2’: 0.028948954164343066, ‘p1’: 0.0003344640625276322, ‘p2’: -0.0015686553848317413, ‘k3’: -0.0010536688268860733}, ‘micasense rededge 1280 960 brown 1.1458 red’: {‘projection_type’: ‘brown’, ‘width’: 1280, ‘height’: 960, ‘focal_x’: 1.1589486882430866, ‘focal_y’: 1.1589486882430866, ‘c_x’: 0.013873746790016624, ‘c_y’: -0.005741079315444213, ‘k1’: -0.07691144911351784, ‘k2’: 0.07797061334372792, ‘p1’: 0.0012375969417238177, ‘p2’: -0.0016315378282242407, ‘k3’: 0.034571675868073144}}
[INFO] crop: 3
[INFO] debug: False
[INFO] dem_decimation: 1
[INFO] dem_euclidean_map: False
[INFO] dem_gapfill_steps: 3
[INFO] dem_resolution: 10.0
[INFO] depthmap_resolution: 640
[INFO] dsm: True
[INFO] dtm: True
[INFO] end_with: odm_report
[INFO] fast_orthophoto: True
[INFO] feature_quality: medium
[INFO] feature_type: sift
[INFO] force_gps: False
[INFO] gcp: None
[INFO] geo: None
[INFO] gps_accuracy: 10
[INFO] ignore_gsd: False
[INFO] matcher_distance: 0
[INFO] matcher_neighbors: 8
[INFO] matcher_type: flann
[INFO] max_concurrency: 4
[INFO] merge: all
[INFO] mesh_octree_depth: 10
[INFO] mesh_point_weight: 4
[INFO] mesh_samples: 1.0
[INFO] mesh_size: 200000
[INFO] min_num_features: 8000
[INFO] name: 8a82c5d1-3a75-4b3c-8df9-012c0ca21ed9
[INFO] opensfm_depthmap_method: BRUTE_FORCE
[INFO] opensfm_depthmap_min_consistent_views: 3
[INFO] opensfm_depthmap_min_patch_sd: 1
[INFO] optimize_disk_space: False
[INFO] orthophoto_compression: DEFLATE
[INFO] orthophoto_cutline: False
[INFO] orthophoto_no_tiled: False
[INFO] orthophoto_png: False
[INFO] orthophoto_resolution: 10.0
[INFO] pc_classify: True
[INFO] pc_csv: False
[INFO] pc_ept: False
[INFO] pc_filter: 2.5
[INFO] pc_las: False
[INFO] pc_quality: medium
[INFO] pc_rectify: False
[INFO] pc_sample: 0
[INFO] primary_band: auto
[INFO] project_path: /var/www/data
[INFO] radiometric_calibration: camera+sun
[INFO] rerun: None
[INFO] rerun_all: False
[INFO] rerun_from: [‘dataset’, ‘split’, ‘merge’, ‘opensfm’, ‘openmvs’, ‘odm_filterpoints’, ‘odm_meshing’, ‘mvs_texturing’, ‘odm_georeferencing’, ‘odm_dem’, ‘odm_orthophoto’, ‘odm_report’]
[INFO] resize_to: 2048
[INFO] skip_3dmodel: True
[INFO] skip_band_alignment: False
[INFO] sm_cluster: True
[INFO] smrf_scalar: 1.25
[INFO] smrf_slope: 0.15
[INFO] smrf_threshold: 0.5
[INFO] smrf_window: 18.0
[INFO] split: 50
[INFO] split_multitracks: False
[INFO] split_overlap: 30.0
[INFO] texturing_data_term: area
[INFO] texturing_outlier_removal_type: gauss_clamping
[INFO] texturing_skip_global_seam_leveling: True
[INFO] texturing_skip_local_seam_leveling: False
[INFO] texturing_tone_mapping: none
[INFO] tiles: False
[INFO] time: False
[INFO] use_3dmesh: False
[INFO] use_exif: False
[INFO] use_fixed_camera_params: False
[INFO] use_hybrid_bundle_adjustment: False
[INFO] use_opensfm_dense: False
[INFO] verbose: False
[INFO] ==============
[INFO] Running dataset stage
[INFO] Loading dataset from: /var/www/data/8a82c5d1-3a75-4b3c-8df9-012c0ca21ed9/images
[INFO] Loading 1310 images
[INFO] Found 1310 usable images
[INFO] Parsing SRS header: WGS84 UTM 10N
[INFO] Finished dataset stage
[INFO] Running split stage
[INFO] Setting max-concurrency to 3 to better handle remote splits
[INFO] Large dataset detected (1310 photos) and split set at 50. Preparing split merge.
[INFO] Reconstruction will use 262 images from auto band
[INFO] Wrote camera_models_overrides.json to OpenSfM directory
[INFO] Writing exif overrides
[INFO] Maximum photo dimensions: 1280px
[INFO] Altitude data detected, enabling it for GPS alignment

======No errors until this below

[INFO] Found 6 submodels with valid orthophotos and cutlines
[INFO] 6 valid orthophoto rasters to merge
Traceback (most recent call last):
File “/code/run.py”, line 69, in
app.execute()
File “/code/stages/odm_app.py”, line 83, in execute
self.first_stage.run()
File “/code/opendm/types.py”, line 361, in run
self.next_stage.run(outputs)
File “/code/opendm/types.py”, line 361, in run
self.next_stage.run(outputs)
File “/code/opendm/types.py”, line 342, in run
self.process(self.args, outputs)
File “/code/stages/splitmerge.py”, line 295, in process
orthophoto.merge(all_orthos_and_ortho_cuts, tree.odm_orthophoto_tif, orthophoto_vars)
File “/code/opendm/orthophoto.py”, line 173, in merge
raise ValueError(“Inputs must be at least 4-band rasters”)
ValueError: Inputs must be at least 4-band rasters

Welcome!

Please provide salient details, if possible:

  1. Machine specs & ODM versions
  2. Method of install/run of ODM
  3. Sample data
  4. Processing Parameters

Hi,
Thanks for responding.
I am using Ubuntu 20.04 os
Used Docker to install most recent version, of: Webodm, nodeodm, clusterodm .
Link to test data, let me know if you need more:

Processing Parameters:
[INFO] DTM is turned on, automatically turning on point cloud classification
[INFO] Initializing ODM - Mon Dec 21 00:02:16 2020
[INFO] ==============
[INFO] build_overviews: False
[INFO] camera_lens: auto
[INFO] cameras: {‘micasense rededge 1280 960 brown 1.1458 blue’: {‘projection_type’: ‘brown’, ‘width’: 1280, ‘height’: 960, ‘focal_x’: 1.1589626608202381, ‘focal_y’: 1.1589626608202381, ‘c_x’: 0.026384410787813894, ‘c_y’: 0.005679101753941108, ‘k1’: -0.07340217251236827, ‘k2’: 0.07753744027240361, ‘p1’: 0.0009980679310383678, ‘p2’: -0.0012260105725874844, ‘k3’: 0.03545901380030076}, ‘micasense rededge 1280 960 brown 1.1458 green’: {‘projection_type’: ‘brown’, ‘width’: 1280, ‘height’: 960, ‘focal_x’: 1.1573314223704725, ‘focal_y’: 1.1573314223704725, ‘c_x’: 0.003890121046317773, ‘c_y’: 0.002109008131436674, ‘k1’: -0.07486889193429358, ‘k2’: 0.08252170048864226, ‘p1’: 0.0009666814441764056, ‘p2’: -0.0010383507298765099, ‘k3’: 0.03552783181362917}, ‘micasense rededge 1280 960 brown 1.1458 rededge’: {‘projection_type’: ‘brown’, ‘width’: 1280, ‘height’: 960, ‘focal_x’: 1.1597642212804677, ‘focal_y’: 1.1597642212804677, ‘c_x’: -0.003525154610966184, ‘c_y’: 0.008145481915915163, ‘k1’: -0.07737891237197571, ‘k2’: 0.07689628713429875, ‘p1’: 0.00021171960763726925, ‘p2’: -0.0015645923530165457, ‘k3’: 0.034235592463022144}, ‘micasense rededge 1280 960 brown 1.1458 nir’: {‘projection_type’: ‘brown’, ‘width’: 1280, ‘height’: 960, ‘focal_x’: 1.159903942931982, ‘focal_y’: 1.159903942931982, ‘c_x’: 0.021440182651411517, ‘c_y’: 0.011810288927861026, ‘k1’: -0.06046732901782252, ‘k2’: 0.028948954164343066, ‘p1’: 0.0003344640625276322, ‘p2’: -0.0015686553848317413, ‘k3’: -0.0010536688268860733}, ‘micasense rededge 1280 960 brown 1.1458 red’: {‘projection_type’: ‘brown’, ‘width’: 1280, ‘height’: 960, ‘focal_x’: 1.1589486882430866, ‘focal_y’: 1.1589486882430866, ‘c_x’: 0.013873746790016624, ‘c_y’: -0.005741079315444213, ‘k1’: -0.07691144911351784, ‘k2’: 0.07797061334372792, ‘p1’: 0.0012375969417238177, ‘p2’: -0.0016315378282242407, ‘k3’: 0.034571675868073144}}
[INFO] crop: 3
[INFO] debug: True
[INFO] dem_decimation: 1
[INFO] dem_euclidean_map: False
[INFO] dem_gapfill_steps: 3
[INFO] dem_resolution: 8.0
[INFO] depthmap_resolution: 640
[INFO] dsm: True
[INFO] dtm: True
[INFO] end_with: odm_report
[INFO] fast_orthophoto: False
[INFO] feature_quality: high
[INFO] feature_type: sift
[INFO] force_gps: False
[INFO] gcp: None
[INFO] geo: None
[INFO] gps_accuracy: 10
[INFO] ignore_gsd: False
[INFO] matcher_distance: 0
[INFO] matcher_neighbors: 8
[INFO] matcher_type: flann
[INFO] max_concurrency: 8
[INFO] merge: all
[INFO] mesh_octree_depth: 10
[INFO] mesh_point_weight: 4
[INFO] mesh_samples: 1.0
[INFO] mesh_size: 200000
[INFO] min_num_features: 8000
[INFO] name: 043bca28-fe89-4fe4-8a3c-2b4ad22620c9
[INFO] opensfm_depthmap_method: PATCH_MATCH
[INFO] opensfm_depthmap_min_consistent_views: 3
[INFO] opensfm_depthmap_min_patch_sd: 1
[INFO] optimize_disk_space: False
[INFO] orthophoto_compression: DEFLATE
[INFO] orthophoto_cutline: False
[INFO] orthophoto_no_tiled: False
[INFO] orthophoto_png: False
[INFO] orthophoto_resolution: 5
[INFO] pc_classify: True
[INFO] pc_csv: False
[INFO] pc_ept: False
[INFO] pc_filter: 2.5
[INFO] pc_las: False
[INFO] pc_quality: medium
[INFO] pc_rectify: False
[INFO] pc_sample: 0
[INFO] primary_band: auto
[INFO] project_path: /var/www/data
[INFO] radiometric_calibration: camera
[INFO] rerun: None
[INFO] rerun_all: False
[INFO] rerun_from: [‘dataset’, ‘split’, ‘merge’, ‘opensfm’, ‘openmvs’, ‘odm_filterpoints’, ‘odm_meshing’, ‘mvs_texturing’, ‘odm_georeferencing’, ‘odm_dem’, ‘odm_orthophoto’, ‘odm_report’]
[INFO] resize_to: 2048
[INFO] skip_3dmodel: True
[INFO] skip_band_alignment: False
[INFO] sm_cluster: True
[INFO] smrf_scalar: 1.25
[INFO] smrf_slope: 0.15
[INFO] smrf_threshold: 0.5
[INFO] smrf_window: 18.0
[INFO] split: 50
[INFO] split_multitracks: False
[INFO] split_overlap: 30.0
[INFO] texturing_data_term: area
[INFO] texturing_outlier_removal_type: gauss_clamping
[INFO] texturing_skip_global_seam_leveling: True
[INFO] texturing_skip_local_seam_leveling: False
[INFO] texturing_tone_mapping: none
[INFO] tiles: False
[INFO] time: False
[INFO] use_3dmesh: False
[INFO] use_exif: False
[INFO] use_fixed_camera_params: False
[INFO] use_hybrid_bundle_adjustment: False
[INFO] use_opensfm_dense: False
[INFO] verbose: True

Below please find:
machine specs.

Primary Machine specs:
H/W path Device Class Description

                                system         HP Z800 Workstation (FF825AV)

/0 bus 0AECh
/0/1 memory 128KiB BIOS
/0/5 processor Intel® Xeon® CPU
/0/5/7 memory 256KiB L1 cache
/0/5/8 memory 1MiB L2 cache
/0/5/9 memory 12MiB L3 cache
/0/6 processor Intel® Xeon® CPU
/0/6/a memory 256KiB L1 cache
/0/6/b memory 1MiB L2 cache
/0/6/c memory 12MiB L3 cache
/0/46 memory 96GiB System Memory

Using 1 additional processing node. Node Specs:
H/W path Device Class Description

                                system         System Product Name (SKU)

/0 bus MAXIMUS V FORMULA
/0/0 memory 64KiB BIOS
/0/4 processor Intel® Core™ i7-3770 CPU
/0/4/5 memory 32KiB L1 cache
/0/4/6 memory 256KiB L2 cache
/0/4/7 memory 8MiB L3 cache
/0/1 memory 32GiB System memory

1 Like

link to log:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.