Not enough supported images


#1

Hi there,

I have an issue where I can’t find any solution here in the Forum. So hopefully you can help me. I’m running ODM in a Windows10 Docker environment. Docker is Version 2.0.0.0-win78 (28905). ODM is the latest Version. I use the following text inside the Powershell command line to start docker:

docker run -it --rm -v “$(pwd)/images:/code/images” opendronemap/OpenDroneMap

Actually I used more parameters but as I can’t run it properly, I reduced it to that. The current folder is the one where there is the “images” folder inside. After starting, ODM tells me:

[DEBUG] Loading dataset from: /code/images
[DEBUG] /code/images
[ERROR] Not enough supported images in /code/images

If I rename the folder, Docker tells me that it can’t mount the folder. If the folder name is correct, I don’t get any message by docker, but the one above by ODM. So obviously the path is correct. Inside the folder there are 1200 JPG images with GPS in the EXIF. Until October everything went smooth but now that I use ODM again, it downloaded the latest ODM version and nothing works. Any suggestions?


#2

Try with:

  1. place your JPGs in a folder named “images” (for example /my/project/images) , then simply run:

docker run -ti --rm -v /my/project:/datasets/code opendronemap/opendronemap --project-path /datasets


#3

Hi pierotofy,

Thanks for your quick response. I tried your string and it worked - just like that other one. ODM can “connect” to the images folder but can’t read any images although the folder is full of it. So it’s the same like described above. Does anyone else have the same problem?


#4

I’ve been having the same issue too - I had ODM up and running a couple of months ago, and now the same code doesn’t work. Same issues as you GISSpezialist


#5

Any news here? I can’t go on working but I also don’t have a clue how to repair this… any help is highly appreciated.


#6

Make sure that your docker volume is being mounted properly.

If you issue:

docker run -ti --rm -v /my/project:/datasets/code --entrypoint ls opendronemap/odm /datasets/code/images

You should see the list of your images. If you don’t, something might be preventing docker from mounting the /my/project path.